Author Topic: Simutrans on linux (debian)  (Read 700 times)

0 Members and 1 Guest are viewing this topic.

Offline EloquentCorpse

Simutrans on linux (debian)
« on: June 18, 2017, 05:13:43 PM »
Hi,

Where do I place the pak files on a linux pc?

Also has anyone done a good music pak as my simutrans is silent except for the odd train noise

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4675
  • Total likes: 170
  • Helpful: 108
  • Languages: EN, NO
Re: Simutrans on linux (debian)
« Reply #1 on: June 18, 2017, 05:36:48 PM »
Unless you are using some modified build, pak sets are installed as subdirectories in the Simutrans program directory, while (unless single-user installation is used) add-on pak files go in the simutrans configuration/save-game directory in each user's home directory.

Simutrans comes with music, but it may be that MIDI playback isn't supported on your system. (I play with neither sound nor music, though.)

Offline Vladki

Re: Simutrans on linux (debian)
« Reply #2 on: June 18, 2017, 06:02:41 PM »
pak files go to ~/simutrans/pakXY, or ~/simutrans/addons/pakXY. If you have installed from distribution repository (debian) it may be also i ~/.simutrans/...

To play MIDI music you need midi player installed. I use timidity.

Offline EloquentCorpse

Re: Simutrans on linux (debian)
« Reply #3 on: June 18, 2017, 08:47:46 PM »


This is what my simutrans directory looks like :/

Also I installed timidty but still says no music available when looking in Simutrans settings?

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2593
  • Total likes: 289
  • Helpful: 89
  • D'oh
    • by An_dz
  • Languages: PT, EN, (it, de)
Re: Simutrans on linux (debian)
« Reply #4 on: June 18, 2017, 09:01:20 PM »
That's your user directory, paksets must be installed in the same directory Simutrans is installed (where the executable is).

Offline EloquentCorpse

Re: Simutrans on linux (debian)
« Reply #5 on: June 19, 2017, 07:25:33 PM »
Thanks btw I managed to find the correct directory

You can use below command to copy the folderrs to the correct directory (if anyone else comes across this)

sudo cp -r simutrans /usr/share/games/simutrans

Music still doesn't work however. I have timidity installed :/

I have this error


Offline Juliusan

Re: Simutrans on linux (debian)
« Reply #6 on: July 19, 2017, 09:12:06 PM »
Yes, I have the same problem. Simutrans doesn't have sound on Debian Stretch. It had sound before and stopped having it after I have upgraded Debian Jessie to Stretch. I've tried to install old simutrans version (the one, which was before the upgrade) and the sound started working again. So it has something to do with simutrans changes between 111.2.2 (newest in Jessie) and 120.1.3 (currently in Stretch).

I've attached a log file with -debug 5 enabled. It contains a line "Midi disabled ...", however I cannot seem to find the reason why. I've only started simutrans, chose the pack, waited for it to be loaded and then quit.

I do also have timidity installed.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4675
  • Total likes: 170
  • Helpful: 108
  • Languages: EN, NO
Re: Simutrans on linux (debian)
« Reply #7 on: July 20, 2017, 05:04:41 AM »
111.2.2? That was a while ago. Even for Simutrans, a lot of commits have passed since then. There is however no changes in the sound or music code for Linux that look relevant. The few changes there are consist of spelling corrections in comments, logging of a warning and a type changed from long to sint32 (where the only values are 0 and -1). I'm not sure if the official builds switched from SDL to SDL2 for Linux. SDL2 support was mainly for MacOS X if memory serves me right. Then there is the question of whether an official build is used. Do the official releases work? If not, this might be a support case against Debian for some tampering they have done.

Offline Juliusan

Re: Simutrans on linux (debian)
« Reply #8 on: July 20, 2017, 05:22:11 AM »
Yes, I thought it might be related to Debian releases. I'll try to find help there. Debian is quite conservative with updates, to say the least, so yes, until mid June this year, official stable simutrans release was 111.2.2 and now it is 120.1.3 and will be for some two years. Thanks for your answer.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8749
  • Total likes: 305
  • Helpful: 229
  • Languages: De,EN,JP
Re: Simutrans on linux (debian)
« Reply #9 on: July 20, 2017, 05:24:24 AM »
It may be the switch to SDL2, since SDL does not support any unicode language with two letter codes. Or libSDL_mixer was discontinued.

Offline Juliusan

Re: Simutrans on linux (debian)
« Reply #10 on: August 01, 2017, 09:00:51 AM »
Apparently the no sound bug was related to Debian build (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869029) and they've fixed it. Now waiting for the fix to get to stretch.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8749
  • Total likes: 305
  • Helpful: 229
  • Languages: De,EN,JP
Re: Simutrans on linux (debian)
« Reply #11 on: August 01, 2017, 10:09:16 AM »
Well using again SDL instead SDL2 will create lots of troubles for all japanese, korean and chinese users ...