Author Topic: Ups. Delivery rules changed.  (Read 4975 times)

0 Members and 1 Guest are viewing this topic.

Offline pletiplot

Ups. Delivery rules changed.
« on: November 17, 2013, 11:40:10 PM »
I have huge savegame with many trains on pak64. There are some printing works and I deliver the ink intoit. The ink storage in the printing works is 118 boxes, but train capacity is 297 boxes each (or more). Until some patch (I dont remember when I made the upgrade) it worked fine, the printing works were flooded a bit for some time, but worked. But now there is something wrong with that. Now I  have all the ink trains less then 100% loaded and they wait for their ink infinitely. It seems that printing works count the goods on the way and all suppliers stop their supply when the storage is "virtualy" full even the goods did not arive yet. So there is a "factory storage is all on the way but in half loaded trains" deadlock (shortly FSIAotWbiHLT-D)
So what is the solution? Mathematicaly the capacity of all trains delivering the ink must be under 118 or I must set up the minimum load on 118 together or do some "one per month" turn sometimes.
Any other ideas?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8752
  • Total likes: 305
  • Helpful: 229
  • Languages: De,EN,JP
Re: Ups. Delivery rules changed.
« Reply #1 on: November 18, 2013, 12:09:13 AM »
The capacity for on the way should be not enforced. It is set in simuconf.tab "maximum_intransit_percentage = 0". Load your game, goto to new world->new world->settings then change on the economy tab to zero, close all dialoges and save the game, reload.

Offline pletiplot

Re: Ups. Delivery rules changed.
« Reply #2 on: November 18, 2013, 12:31:40 AM »
Thanks. There was 500, I don't know why. Simutrans got many new features, I just cannot keep the pace.

Offline pletiplot

Re: Ups. Delivery rules changed.
« Reply #3 on: November 18, 2013, 12:43:15 AM »
Now I see that not only ink train had that problem. Half of wood trains had it as well. So big part of my was just standing in the stations. Now I released them and I am afraiding of jams  :police:

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4677
  • Total likes: 170
  • Helpful: 108
  • Languages: EN, NO
Re: Ups. Delivery rules changed.
« Reply #4 on: November 18, 2013, 05:58:39 AM »
Simutrans got many new features, I just cannot keep the pace.

And to think that Simutrans actually gets lots of complaints that the pace of Simutrans development is too slow.

Offline pletiplot

Re: Ups. Delivery rules changed.
« Reply #5 on: November 18, 2013, 07:37:22 PM »
I allways play simutrans for few months and then have a break for a year or two. So the leaps are big for me always. I still cant use all types of signals, not mentioning the multiplayer.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4677
  • Total likes: 170
  • Helpful: 108
  • Languages: EN, NO
Re: Ups. Delivery rules changed.
« Reply #6 on: November 18, 2013, 08:56:13 PM »
I allways play simutrans for few months and then have a break for a year or two. So the leaps are big for me always. I still cant use all types of signals, not mentioning the multiplayer.

It's much the same with me, except that I hang around this forum whether I play Simutrans at the moment or not, so I know what's going on. A few months active playing, then long breaks. I've been playing the same map for years now.

Offline Giziar

Re: Ups. Delivery rules changed.
« Reply #7 on: April 02, 2016, 11:59:44 AM »
The capacity for on the way should be not enforced. It is set in simuconf.tab "maximum_intransit_percentage = 0". Load your game, goto to new world->new world->settings then change on the economy tab to zero, close all dialoges and save the game, reload.

With apologies to resurrect such an old post. But only found about this setting today. I have a save that I started some years (and some Simutrans versions) ago and run into the same thing. However when trying to apply the option Prissi offered it doesn't seem to work. Any clue what might be causing that?
If I had to guess I think the save originally has been started with 1.11 somewhere around late 2011/early 2012

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2593
  • Total likes: 289
  • Helpful: 89
  • D'oh
    • by An_dz
  • Languages: PT, EN, (it, de)
Re: Ups. Delivery rules changed.
« Reply #8 on: April 03, 2016, 09:09:21 PM »
Editing the simuconf.tab only applies to new games, you need to change with the configuration dialogue, I believe most paksets use "i" or "n" for the shortcut.

Offline Giziar

Re: Ups. Delivery rules changed.
« Reply #9 on: April 04, 2016, 08:46:04 PM »
Whatever I change in the configuration dialogue (following the route Prissi mentioned Load your game, goto to new world->new world->settings then change on the economy tab) the "maximum_intransit_percentage" is always reverted back to 500 upon reloading the save game.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8752
  • Total likes: 305
  • Helpful: 229
  • Languages: De,EN,JP
Re: Ups. Delivery rules changed.
« Reply #10 on: April 05, 2016, 12:04:57 AM »
Not everything can be changed by this, so it is not offered by default for pak64.

Offline Giziar

Re: Ups. Delivery rules changed.
« Reply #11 on: June 26, 2016, 04:25:02 PM »
Any chance that this setting is editable in the current save game with a Hex-Editor?
As I am finding out that this new in-transit setting is currently taking a bit of joy out of my longlasting save.
Once had to use it when the speed of the game changed between versions so I am willing to give it a try if such is possible.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2593
  • Total likes: 289
  • Helpful: 89
  • D'oh
    • by An_dz
  • Languages: PT, EN, (it, de)
Re: Ups. Delivery rules changed.
« Reply #12 on: June 26, 2016, 05:07:14 PM »
If you want to hex edit, it's probably in the beginning of the file. Look for the previous value and try changing it.

I prefer to change the save type in the simuconf.tab to xml as it's easier to change the values.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4677
  • Total likes: 170
  • Helpful: 108
  • Languages: EN, NO
Re: Ups. Delivery rules changed.
« Reply #13 on: June 26, 2016, 06:15:01 PM »
Any chance that this setting is editable in the current save game with a Hex-Editor?
As I am finding out that this new in-transit setting is currently taking a bit of joy out of my longlasting save.
Once had to use it when the speed of the game changed between versions so I am willing to give it a try if such is possible.

If you want to hex edit, it's probably in the beginning of the file. Look for the previous value and try changing it.

The game is compressed by default, so it needs to be decompressed first.

I prefer to change the save type in the simuconf.tab to xml as it's easier to change the values.

I can imagine most text editors grinding to a halt trying to render a Simutrans game saved in XML format. Someone familiar with hex editors probably know of something that works, though.

Offline Vladki

Re: Ups. Delivery rules changed.
« Reply #14 on: June 26, 2016, 07:06:52 PM »
Add "dialog_tool[27]=,i" to your menuconf.tab and you can edit that in-game after pressing "i".
That's the default in pak128.britain. Other paksets may have some other key assigned to that.

Offline Giziar

Re: Ups. Delivery rules changed.
« Reply #15 on: July 11, 2016, 08:31:10 PM »
If you want to hex edit, it's probably in the beginning of the file. Look for the previous value and try changing it.

I prefer to change the save type in the simuconf.tab to xml as it's easier to change the values.

Right.
Huge, huge, no even more than huge thanks for putting me on the right track.

Saving the savefile in xml was the easy step.
Save size did slightly increase indeed (size became 4.67GB)

Then opening the file with an xml editor.
At first no clue where to look for. Till I got the bright idea to start with a new save and use a rather peculiar value for the intransit value.
When I could locate the intransit value I thought I knew what to change (some boolean value from false to true)
However saving the file did work but opening in Simutrans didn't. As save size had shrunk to about 700MB I thought the xml editor was to blame

Found XML Validatorbuddy which is able to open rather large files. And behold I could save the file and open it in Simutrans.
So far no real progress with the amount of goods in transit so I decided to experiment a bit with the value. And yes it works!
Due to having a rather large map (4096*4096) and slow transit for some goods (ships) I decided to settle for a value of 2000. And yes, more goods are finally on their way.
So, save saved. Altered save method back to compressed and opened and saved once more.

So once more; thank you very very very much.

(Note: don't try this at home if your computer is not up to the task. I'm lucky (crazy?) enough to have bought a new computer this year with quite some memory)
I'm happy now.

Offline Vladki

Re: Ups. Delivery rules changed.
« Reply #16 on: July 11, 2016, 08:54:19 PM »
why didn't you try the menuconf modification I sugessted? It is much more easier and less error prone than editing the xml

Offline Giziar

Re: Ups. Delivery rules changed.
« Reply #17 on: July 11, 2016, 09:14:39 PM »
why didn't you try the menuconf modification I sugessted? It is much more easier and less error prone than editing the xml

I tried. However after pressing the i only the help menu opened.
Tried the solution offered by Prissi on 18-11-2013 before as well, didn't work.