Author Topic: Train with erratic behaviour  (Read 870 times)

0 Members and 1 Guest are viewing this topic.

Offline accord2

Train with erratic behaviour
« on: July 07, 2016, 07:22:02 PM »
I made a train line with public service and started using with trains in normal player. In the first years everything was fine but now one of my trains has an erratic behaviour. He goes from station A to station B and then reverse and go to A again instead of going to C. He repeats this cycle endlessly, even if I order him to go to C or D, he just ignores me and continues in the cycle. The only was to stop this from happening is sending him to the depot but once he gets out he starts again. Do you know a way of solving this? I thought it was caused because of signalling but I changed signals with others different and he continued. Thanks :)

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15688
  • Total likes: 395
  • Helpful: 174
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Train with erratic behaviour
« Reply #1 on: July 07, 2016, 10:44:41 PM »
Hello, welcome to the forum. I am sorry that you are having trouble. May I ask that you upload a saved game in which this can be reproduced so that I can try to find what the problem is?
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Offline accord2

Re: Train with erratic behaviour
« Reply #2 on: July 08, 2016, 07:22:26 AM »
It is between Rustinghall and Rustmead.
https://www.dropbox.com/s/i4fj8bv3tmklt1j/NST%2029.sve?dl=0

Offline Vladki

Re: Train with erratic behaviour
« Reply #3 on: July 08, 2016, 04:48:34 PM »
How about a permission for the player to use publicly owned track? Or a missing piece of track or catenary.

Offline accord2

Re: Train with erratic behaviour
« Reply #4 on: July 08, 2016, 07:05:01 PM »
How about a permission for the player to use publicly owned track? Or a missing piece of track or catenary.

What is permission for player to use owned track and how I get that? I have other two lines in that use public lines and work fine. The track in fine because the train made the journey before...

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15688
  • Total likes: 395
  • Helpful: 174
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Train with erratic behaviour
« Reply #5 on: July 09, 2016, 10:18:39 AM »
I cannot reproduce this on the latest (unreleased, except in sources) development version of Simutrans-Experimental, but a number of bugs of this sort have been fixed since the latest released version (11.x), which is now somewhat old.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Offline Spenk009

Re: Train with erratic behaviour
« Reply #6 on: July 09, 2016, 11:01:46 AM »
The box for "Reverse route" was ticked. This may have been unintentional, but related to the cause. Unticking solves the issue.

I was using 11.35 with the pak from the time.

Offline accord2

Re: Train with erratic behaviour
« Reply #7 on: July 10, 2016, 08:28:39 PM »
The box for "Reverse route" was ticked. This may have been unintentional, but related to the cause. Unticking solves the issue.

I was using 11.35 with the pak from the time.
Thanks :)