Author Topic: Incorrect Version Number On Initial Loading Screen  (Read 758 times)

0 Members and 1 Guest are viewing this topic.

Offline Curly_kleg

Incorrect Version Number On Initial Loading Screen
« on: May 27, 2016, 09:43:17 PM »
Hi all,

I'm not entirely sure this belongs here - it's not really a bug, so much, but more so than anything else.

I have SimuTrans installed via Steam and today it (automatically, on start) updated from 120.1.1 to 120.1.3. This is reflected in the main-menu dialogue ("This is Simutrans: Version 120.1.3 Feb 2 2016") but the initial loading screen (immediately following packset selection) still displays "Pak 128.Britain 1.17 Simutrans 120.1.1". Not sure if this is to do with the packset or with the main SimuTrans application.

As I said, not really a bug, but caused me minor confusion for a second.

Many thanks

Offline Spacethingy

Re: Incorrect Version Number On Initial Loading Screen
« Reply #1 on: May 27, 2016, 10:19:10 PM »
Hi Curly_kleg, that's just a title used by the pak; I guess it's supposed to show the version of Simutrans the pak was designed for. My nightly r7793 says the same thing when loading Pak 128.Britain. The "This is Simutrans..." text is the actual program version.

You're right, it is rather confusing. For instance, I grabbed a nightly pak64, and its splash screen says it's for version 120.0.1, which was quite a long time ago!
Life is like a new Simutrans transformer:

You only get one of them, and you can't have it on a slope.