Author Topic: 120.2 not responding  (Read 771 times)

0 Members and 1 Guest are viewing this topic.

Offline ronnie89b

120.2 not responding
« on: February 15, 2017, 04:51:53 PM »
Hi guys!
I've a problem with 120.2 version of the game. After 1-2 minutes of playing, the game simply doesn't responding. No crash, no error message, just not responding. 120.1.3 has this same problem, but 120.1.2 and the nightly versions work perfectly.
It comes out only my laptop(win8.1), on my PC (win7) the game runs for hours, without a single error.
Any idea what's the problem?

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2593
  • Total likes: 289
  • Helpful: 89
  • D'oh
    • by An_dz
  • Languages: PT, EN, (it, de)
Re: 120.2 not responding
« Reply #1 on: February 15, 2017, 06:37:28 PM »
Is it the GDI or SDL build? Or have you installed it with the the installer?

Offline ronnie89b

Re: 120.2 not responding
« Reply #2 on: February 15, 2017, 11:16:13 PM »
I tried both with the same result. I don't use the installer.

Offline DrSuperGood

Re: 120.2 not responding
« Reply #3 on: February 16, 2017, 01:02:02 AM »
Does the computer still respond? Maybe it is a driver bug interfacing with SDL/GDI, as laptops are notorious for that.

Offline ronnie89b

Re: 120.2 not responding
« Reply #4 on: February 16, 2017, 02:41:33 PM »
Yes, it responds. I can click on the x button, and it qiuts after a few seconds. If it's a laptop error, i use the nightly versions, so it's not a big deal.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4747
  • Total likes: 183
  • Helpful: 108
  • Languages: EN, NO
Re: 120.2 not responding
« Reply #5 on: February 16, 2017, 03:35:03 PM »
Sounds like Simutrans is stuck processing a flood of events, never getting around to doing rendering or logic.