Author Topic: [r8213] Can't build a bridge ending under an elevated way or at a station  (Read 574 times)

0 Members and 1 Guest are viewing this topic.

Offline gauthier

Using Simutrans nightly r8213 for linux with pak128 2.6.

This concern is about bridges ending at a cliff or at an elevated way (no slope, so no usual bridge slope-based starting piece).

I first built a bridge there and then added an elevated way above. There was only one straight piece of bridge above the - non-navigable - river. Now I want replace it so I just destroyed it and can't rebuild it unless I remove the piece of elevated way above. Same happens when there's a piece of track with a station on it at one end.

EDIT: changed the screenshots for clearer ones.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8798
  • Total likes: 319
  • Helpful: 229
  • Languages: De,EN,JP
The correct behaviour is to forbid the removing of the bridge under an elevated way. But when introducing elevated ways, there was consent to allow for this and other glitches, since these are anyway advanced features.

Offline gauthier

In the end, the elevated way is not above a piece of bridge, the only piece (one single tile) of bridge is above the river.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4812
  • Total likes: 191
  • Helpful: 108
  • Languages: EN, NO
I don't remember it ever having been possible to build a single bridge tile. At least one end (ramp) has been required.

Offline gauthier

Please see the attached picture. I use this a lot.

Anyway, it looks like the game tests only if building a ramp is possible. Then it builds without ramp if possible.