Author Topic: Sudden city growth  (Read 361 times)

0 Members and 1 Guest are viewing this topic.

Offline zook2

Sudden city growth
« on: August 23, 2017, 03:10:49 AM »
A weird thing happened on my new map (game version 12.2 ra31077e). I wondered why my network was slowly going bankrupt. Then I noticed that three game months ago, *all* cities on the map (I didn't check them all, but a dozen chosen at random should be proof enough) suddenly more than doubled in population, while passenger levels slowly dropped to nothing.

That must have happened after I reloaded a savegame because of a crash. Before loading it I remembered to switch on autosave in the config file, but I could swear that's the only thing I changed.

Any idea what went wrong here?

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15552
  • Total likes: 382
  • Helpful: 172
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Sudden city growth
« Reply #1 on: August 23, 2017, 01:57:40 PM »
Thank you for the report. I am afraid that I cannot diagnose this from screenshots; are you able to upload a saved game in which this issue can reliably be reproduced?
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.

Offline zook2

Re: Sudden city growth
« Reply #2 on: August 23, 2017, 02:21:38 PM »
Here's the only savefile I have, but it's after the problem occurred.

http://www37.zippyshare.com/v/6mWxKMQx/file.html

Apart from the sudden growth - is there any reason why city growth leads to decreasing passenger levels?

Offline jamespetts

  • Simitrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 15552
  • Total likes: 382
  • Helpful: 172
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Sudden city growth
« Reply #3 on: August 26, 2017, 03:41:48 PM »
I have just pushed a fix that caused cities to record the wrong population numbers just after map generation, which was fixed on re-loading. Now, the towns give the correct population numbers straight after map generation, which is consistent with the situation after a save/load cycle.

It is difficult to say whether this was the cause of your problem, but it would be useful to know whether you experience anything like this again after the next nightly build.
Download Simutrans-Extended.

Want to help with development? See here for things to do for coding, and here for information on how to make graphics/objects.

Follow Simutrans-Extended on Facebook.