Author Topic: Train doesn't load wood from Tree Plantation  (Read 249 times)

0 Members and 1 Guest are viewing this topic.

Offline MirceaKitsune

Train doesn't load wood from Tree Plantation
« on: September 24, 2017, 02:14:46 AM »
Greetings! I'm rather new to this lovely little game, which I remember briefly messing around with several years ago. I decided to give it a try again after someone reminded me of it, and now I'm getting back into it pretty quickly :)

Anyway I found a weird problem. I was thinking of reporting it as a bug... however since I'm not fully accustomed to the rules of Simutrans, I might be missing something so I figured it's best if I ask first.

I'm trying to get a train to deliver wood from a Tree Plantation to a Paper Mill. I set up the rails in between the two locations, created cargo stations at each, created a train depot, and bought a train with a wood car which I configured to go between the two stations. The train travels back and forth as expected, however it never loads the wood when departing the station of the plantation! I tried different rails, different station types, a different engine with different cars, and checked everything I could possibly think of... yet nothing does the trick for me. The train station definitely has the wood waiting at its location, and even knows of the other station at which it's supposed to be delivered... the train on the other hand makes it clear that wood is supposed to be transported, so why is nothing loaded onto the train when it stops at the station?

Here is a screenshot of my scenario, with windows opened for all of the items involved. It shows the train leaving the station it was supposed to load the wood from, yet it abandons it completely empty. My Simutrans version is 120.2.2 r1234 and I'm using the pak128 graphics.


Online Leartin

  • Devotee
  • *
  • Posts: 800
  • Total likes: 287
  • Helpful: 44
  • !!!!!This user was banned for double posting!!!!!
  • Languages: DE, EN
Re: Train doesn't load wood from Tree Plantation
« Reply #1 on: September 24, 2017, 07:23:39 AM »
I can't judge by the screenshot, so just to rule out one of the most common errors - that 'train' doesn't happen to be longer than one tile? A wagon must be completely in the station to get loaded, if it's only a tiny bit outside it doesn't count.

Offline MirceaKitsune

Re: Train doesn't load wood from Tree Plantation
« Reply #2 on: September 24, 2017, 01:00:59 PM »
I can't judge by the screenshot, so just to rule out one of the most common errors - that 'train' doesn't happen to be longer than one tile? A wagon must be completely in the station to get loaded, if it's only a tiny bit outside it doesn't count.

Ahhh! Thank you, that was in fact it :D I made the stations one tile larger and now the train loads what's on them. Perhaps a warning could be implemented later, to notify players about this sort of mistake.

I didn't even realize stations could have more than one tile, I was worried that if I drew more they would become individual stations neighboring one another. What threw me off is that passenger trains with two items (engine and car) would successfully load from one-tile stations, this only seems to not happen with wood trains.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4812
  • Total likes: 191
  • Helpful: 108
  • Languages: EN, NO
Re: Train doesn't load wood from Tree Plantation
« Reply #3 on: September 24, 2017, 01:20:34 PM »
The number of tiles a train requires is listed in the depot window as you build the train. It is perhaps a bit hidden among all the other numbers players have required as essential.

Offline Frank

Re: Train doesn't load wood from Tree Plantation
« Reply #4 on: September 24, 2017, 01:21:30 PM »
Under the compilation, the required station length is displayed.

in this older version
the line: Vehicles: 5 (Station tiles: 3)

version 120.2.2 the line: Station Tiles: 3


Offline MirceaKitsune

Re: Train doesn't load wood from Tree Plantation
« Reply #5 on: September 24, 2017, 03:14:23 PM »
Under the compilation, the required station length is displayed.

in this older version
the line: Vehicles: 5 (Station tiles: 3)

version 120.2.2 the line: Station Tiles: 3

http://www.simutrans-germany.com/translator/data/img/10/depot.txt.png

Noticed that shortly afterward. It makes a lot more sense now.