Author Topic: The sound effects button is locked on mute  (Read 1565 times)

0 Members and 1 Guest are viewing this topic.

Offline Osric

  • *
  • Posts: 8
  • Helpful: 0
The sound effects button is locked on mute
« on: March 30, 2013, 10:06:47 PM »
Hi guys,

Have been playing Simutrans for a few years now and love it. But since installing it on a new PC I'm having a strange problem with the sound. I can check and uncheck the midi sound mute box to toggle on and off no problem, but the sound effects button is locked on mute ??? I have reinstalled tried command line commands and whatever I do I'm condemned to play in silence, which creates far too detached an experience. I would be extremely grateful if someone could provide an explanation and a workaround, I'm gutted at effectively being unable to play. I am playing on Linux Mint

Offline jamespetts

  • Simitrans-Experimental project coordinator
  • Devotee
  • *
  • Posts: 11713
  • Helpful: 90
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: The sound effects button is locked on mute
« Reply #1 on: March 30, 2013, 10:14:58 PM »
Osric - welcome to the forums! You have posted this in the Pak128.Britain forum, but this does not seem to be pakset specific, unless you have tried with other paksets and can get sound to work...?
James E. Petts

Download the experimental version of Simutrans and help to test lots of new features here.

Download Pak128.Britain here.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 7599
  • Helpful: 180
  • Languages: De,EN,JP
Re: The sound effects button is locked on mute
« Reply #2 on: March 30, 2013, 11:15:08 PM »
If you have set -nosound on the commandline, then the sound driver in SDL is not started at the beginning. As a consequence it cannot be enabled later on.

Offline Osric

  • *
  • Posts: 8
  • Helpful: 0
Re: The sound effects button is locked on mute
« Reply #3 on: March 30, 2013, 11:29:43 PM »
I havn't. Get the same issue on my laptop fresh from installation also running Mint 14. Both have the sound option hard wired to mute

Offline Isaac.Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 2741
  • Helpful: 71
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: The sound effects button is locked on mute
« Reply #4 on: March 31, 2013, 03:00:54 AM »
Can you get any non-midi sounds from other applications?
For server and hosting problems and requests, please open a ticket at http://PanamaCityPC.com/support/

Offline An_dz

  • Devotee
  • Administrator
  • *
  • Posts: 1854
  • Helpful: 61
  • D'oh
    • by An_dz
  • Languages: PT, EN
Re: The sound effects button is locked on mute
« Reply #5 on: March 31, 2013, 03:52:54 AM »
Do you have SDL_mixer installed?

Offline Osric

  • *
  • Posts: 8
  • Helpful: 0
Re: The sound effects button is locked on mute
« Reply #6 on: March 31, 2013, 06:24:31 AM »
I have no other sound issues. I can also get the music to work in Simutrans. I notice in the settings/sound menu of Mint, under the applications tab, that sound is set to on but there is a line through the application icon which appears to indicate the sound is not working properly despite the fact that the music is playable. Given that this fault appears on fresh unaltered installations taken directly from the Mint repository on two separate computers this seems unlikely to be a hardware issue. Its a mystery. I'm not familiar with SDL_Mixer. The repository lists libsdl-mixer-gst as the only software meeting the search query for the SDL_mixer and it is not installed. Might this help or are you concerned it might be the source of the problem?

Thanks for replying. I'm gutted I cannot access the sound effects as playing without them ruins it and I appreciate your input.

Offline An_dz

  • Devotee
  • Administrator
  • *
  • Posts: 1854
  • Helpful: 61
  • D'oh
    • by An_dz
  • Languages: PT, EN
Re: The sound effects button is locked on mute
« Reply #7 on: March 31, 2013, 02:27:51 PM »
SDl_mixer is a sound library. I installed in a Ubuntu and it worked.

Plus, can you play the sounds with your media player?

Offline Osric

  • *
  • Posts: 8
  • Helpful: 0
Re: The sound effects button is locked on mute
« Reply #8 on: March 31, 2013, 09:52:12 PM »
I have no problem playing any sound files. The only sound issue I have is with Simutrans. I went to install sdl_mixer and found I do have libsdl_mixer1.2 installed, I assume it comes packaged with Mint 14.

Do you mean can I open up Simutrans and play the sound effect files manually? I haven't found any sound effect files but the midi files for music play fine with a media player and can be enabled in the game anyway. However I'm not sure about the location of the sound effect files and whether they're accessible to test directly with a  player. I might try getting another pak and seeing if the sound will work with that. It would seem that as we know it occurs on 2 machines installed through the repository, either Mint is not handling it for some reason, or the repository has left out a component. Its hard to see how it could be my individual setup or hardware, but then I'm a distinct amateur on these things. Frankly I'm stumped.

Just to update the other basic looking pak that comes with simutrans from the repository has sound effects no problem if that helps pin down some package that I may be missing

« Last Edit: April 01, 2013, 12:18:38 AM by Osric »

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 7599
  • Helpful: 180
  • Languages: De,EN,JP
Re: The sound effects button is locked on mute
« Reply #9 on: April 01, 2013, 08:56:51 PM »
The soundfiels should be next to the pakset, in simutrans/pakXYZ/sound/

Build simutrans yourself: Download the source, copy config.template to config.default, remove the comments before linux, sdl and 16 and maybe in the -DUSE_C line and type make.

It may easily have been configured with no_sound for the distributed built; then you will never get sound.

Offline An_dz

  • Devotee
  • Administrator
  • *
  • Posts: 1854
  • Helpful: 61
  • D'oh
    • by An_dz
  • Languages: PT, EN
Re: The sound effects button is locked on mute
« Reply #10 on: April 01, 2013, 09:39:47 PM »
I think it's easier for him to download a nightly version.
http://www.simutrans.com/download/nightly

Offline Osric

  • *
  • Posts: 8
  • Helpful: 0
Re: The sound effects button is locked on mute
« Reply #11 on: April 03, 2013, 02:56:42 AM »
Thanks for your help guys.

I downloaded the Simutrans file directly and installed a number of PAK files - although not nightly as yet. They all have the sound working normally except 128Britain. Shame I used to play 128Britain all the time. But I'm happy enough with the others for the time being. I absolutely love the game, its so relaxing and has such depth, a real masterpiece. Puts EA's Simcity to shame, although that's faint praise.  A HUGE thankyou to everyone involved in the development and support of this game, its a fantastic achievement

Offline IgorEliezer

  • Devotee
  • Administrator
  • *
  • Posts: 3643
  • Helpful: 63
  • Proud of nothing
    • Igor Eliezer Architect and Urban Planner/Arquiteto e Urbanista
  • Languages: PT, EN, AutoLISP, Python
Re: The sound effects button is locked on mute
« Reply #12 on: April 03, 2013, 03:14:25 AM »
They all have the sound working normally except 128Britain.
Then this topic became a pakset-specific bug report.

I'll move this topic to there.

EDIT: Done.

Sorry for this issue having been so frustrating for you. If you like to play this pakset, it deserves some attention.
« Last Edit: April 03, 2013, 03:27:30 AM by IgorEliezer »

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 7599
  • Helpful: 180
  • Languages: De,EN,JP
Re: The sound effects button is locked on mute
« Reply #13 on: April 03, 2013, 08:19:48 PM »
Some sounds can be enabled via menuconf.tab and copying the wave files from other paks.

Offline The Hood

  • Moderator
  • *
  • Posts: 2739
  • Helpful: 42
  • pak128.Britain developer
Re: The sound effects button is locked on mute
« Reply #14 on: April 13, 2013, 09:34:56 AM »
Is this essentially because sounds don't exist in pak128.Britain? I find them annoying in any game hence I haven't devoted any of my scarce time for simutrans development to them. If other people want sound and are willing to implement it however, I'm happy to incorporate it...