The International Simutrans Forum

 

Author Topic: Long Block Fails Beyond Next Station  (Read 1899 times)

0 Members and 1 Guest are viewing this topic.

Offline dannyman

  • *
  • Posts: 182
Long Block Fails Beyond Next Station
« on: January 11, 2013, 03:45:36 AM »
Heya!


I built a dogbone-style tram system with two single-track sections in the middle.  Each of these sections have one station on them.  The track operates in a loop roughly like so:


(==>--<==>--<==)


For the stations on single-track sections I thought "oh no, deadlock potential" so I built a long-block at the entrance to the section with a regular signal after the section, on the theory that in order to enter the section, a tram would reserve the entire block, through the station, to the next double-track system.


What happened is the tram would stop at the long-block signal, and wait forever.


I tried routing the tram to the next station beyond the single track, and the tram was able to get reservation, through the single-track station without stopping, to the signal at the end of the next double-track, on to the next station.


I realized that since the track reservations are to the end of a station, if there is a single station in a single track section: no problem: if a tram is heading to the station from either side, it is blocked from entering the single-track section, but I feel I will be in trouble if I get multiple stations on the single track.


My feeling is there is a bug here: long block should be grabbing a reservation from the long block signal to the next signal down the line, even if the next signal down the line is after the next station down the line.


Thanks,
-danny

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: Long Block Fails Beyond Next Station
« Reply #1 on: January 11, 2013, 10:03:25 AM »
If you have long block signals at both/all ends of the single track section this should not be a problem. Yes the train only reserves up to the next station but it checks up to the next signal so will not enter if a train is already in the long block.

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Re: Long Block Fails Beyond Next Station
« Reply #2 on: January 11, 2013, 05:38:21 PM »
I've had this same issue, but hadn't got around to drawing a pretty diagram for posting/discussion.

Basically, if you have a series of passing loops between single-platformed stations (ie a station within in every block section), and each loop has only one signal on each side in each direction (both being long block signals, at each respective exit), it gridlocks. If you introduce a "home" signal at the entrance to the loop on each side, so there are now 2 signals on each side, it still gridlocks.

I built my mainline the above fashion on the server game recently, and gave up trying to figure it out. Without the loop entry signals, the trains wouldn't pass the long-block signal to enter the block section even if at the far end the next loop was free to allow exit. With the loop entry signal in place, the loop filled both sides, and then (memory fails me) either a train got stuck stradelling the points, or refused to enter the section at all (I forget which).

If you try pre-signals instead of the long block signals, it also gridlocks (as expected).

I think there must have been changes to the long block signal mechanics at some prior point because the first way used to be my standard signalling setup and worked fine, but now does not.
« Last Edit: January 11, 2013, 07:29:26 PM by AP »

Offline dannyman

  • *
  • Posts: 182
Re: Long Block Fails Beyond Next Station
« Reply #3 on: January 11, 2013, 09:52:05 PM »
A P thank you for confirmation.  I will try to set up a "test case" over the weekend: comparable test lines in Standard and Experimental.


Given all the changes to route-finding in Experimental I am not surprised if long blocks got broken.  :)

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18619
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Long Block Fails Beyond Next Station
« Reply #4 on: January 11, 2013, 10:05:08 PM »
I thought that I had fixed long block signals for the 10.18 release - AP, are you able to upload a saved game in which they do not work correctly?