The International Simutrans Forum

 

Author Topic: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"  (Read 2117 times)

0 Members and 1 Guest are viewing this topic.

Offline Sarlock

  • Devotee
  • *
  • Posts: 1340
  • Languages: EN
I ran a map as a test to see if the behavior from the 7000x2000 map repeated itself and it does: industry does not seem to obey the restriction in "max_factory_spacing_percentage" (set to 33 default) when connecting to other industries.



This results in some very long connections.  It seems random, I've had connections just a few tiles away and ones as far as this example and even farther.

This was on a 4000x500 map with 80 industries and 10 cities.

I didn't think about saving the map until after I closed the game.  :P
« Last Edit: October 09, 2013, 04:45:36 AM by Sarlock »

Offline pwhk

  • *
  • Posts: 60
  • Languages: ZH, EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #1 on: October 09, 2013, 05:09:12 AM »
Apparently, I have a super-short connection in the save I am playing that can literally have goods delivered from the factory to the shop by hauling them on hand  ???

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #2 on: October 09, 2013, 10:34:11 AM »
The code for this appears to be unchanged from Standard (and it is not immediately apparent to me precisely how this works). Can anyone confirm whether this works in Standard?

Offline Sarlock

  • Devotee
  • *
  • Posts: 1340
  • Languages: EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #3 on: October 09, 2013, 02:42:07 PM »
Interesting.  I didn't realize this parameter was available in Standard as well.  I didn't see it in the simuconf for pak64 or pak128.  Will add and test later.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #4 on: October 24, 2013, 10:45:09 PM »
Any progress on testing this in Standard, anyone?

Offline TurfIt

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 1325
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #5 on: October 24, 2013, 11:22:06 PM »
AFAICT the max_factory_spacing_xx parameters only limit how far away a new supplier will be built from a newly built consumer. If the new consumer finds an existing supplier on the map, it will link regardless of distance. There are no parameters to control min/max linking distance. IMHO there should be...

Offline Sarlock

  • Devotee
  • *
  • Posts: 1340
  • Languages: EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #6 on: October 25, 2013, 02:46:11 AM »
My apologies, I had tested this at the time but forgot to provide an update.

I tested this with Standard and it didn't seem to have any effect either.  I didn't even know this parameter was available in Standard, I hadn't seen it used in any of the pak config files.

If it is as TurfIt suggests, then this parameter would be of limited effect/usefulness.
« Last Edit: October 25, 2013, 03:13:44 AM by Sarlock »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [11.12] Industry Spacing Does Not Obey "max_factory_spacing_percentage"
« Reply #7 on: October 25, 2013, 12:35:09 PM »
In light of the above, this topic seems more appropriate in the Standard extension requests forum, to which I have now moved it.