The International Simutrans Forum

 

Author Topic: 11.22 - Reverse allignment bug  (Read 1054 times)

0 Members and 1 Guest are viewing this topic.

Offline Ves

  • Devotee
  • *
  • Posts: 1677
  • Languages: EN, SV, DK
11.22 - Reverse allignment bug
« on: March 14, 2014, 10:15:32 AM »
Im aware you already know about this bug, but I thought to share an observation, in case you have missed it :)

There appears to be a fixed length of 8 tilesteps (½ a tile) between the end of the first vehicle, to the frontend of the first backwardturned vehicle. You can actualy draw a line across all frontends turning backwards, and you see that the length of the vehicles are very different (in the number two from top track, the turned arround vehicle is 9 tilesteps). see the picture:

The arrows points to the 'frontend' of the vehicles: (the uppermost track is a 'correct' convoy, all heading the same way = serves as reference)



How are progres to nail this bug? :)

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: 11.22 - Reverse allignment bug
« Reply #1 on: March 14, 2014, 10:30:11 AM »
I have not been working on it for a long time, as I have had other things on which to work. Thank you for your observations, though. If only I had some insight into what was actually happening in the code so as to bring this about, it would help me greatly, but I really have not gone into the graphics code at all.