The International Simutrans Forum

 

Author Topic: [120.0.1 r7373, Windows 8 64-bit] A few minor bugs...  (Read 1821 times)

0 Members and 1 Guest are viewing this topic.

Offline thunderkiller1996

  • *
  • Posts: 14
  • Languages: EN
[120.0.1 r7373, Windows 8 64-bit] A few minor bugs...
« on: January 30, 2015, 11:28:14 AM »
Hiya folks,

I just installed the latest version of Simutrans (120.0.1) on Windows 8, and there are a few... minor bugs with the latest version.

1) Sometimes, when I'm building various items, the mouse cursor will disappear for no reason. My fix for it is to select the normal Select tool (key A) and then move my invisible cursor to the top left of the screen, click and then, when a dialog box appears with options about what to do with the window, I guess where the first visible bit of screen on the top left is, move the invisible cursor there in then click. The cursor should then re-appear.
2) Sometimes in the Schedule submenu, when first scheduling a vehicle, I cannot select an already existing line-when I click on a line it doesn't select it and the dialog box for a line remains empty. When that happens, I just go back to the main vehicle screen and assign the line from the Garage/Depot/Hangar/Shipyard menu.

I haven't tried running Simutrans in Compatibility Mode yet and seeing if that works, but apart from that those are the only two bugs I have noticed.

Apart from that thanks for your time and I thought I'd bring these little bugs up and see if there is a solution to that.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2839
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: [120.0.1 r7373, Windows 8 64-bit] A few minor bugs...
« Reply #1 on: January 30, 2015, 03:30:19 PM »
1) Sometimes, when I'm building various items, the mouse cursor will disappear for no reason. My fix for it is to select the normal Select tool (key A) and then move my invisible cursor to the top left of the screen, click and then, when a dialog box appears with options about what to do with the window, I guess where the first visible bit of screen on the top left is, move the invisible cursor there in then click. The cursor should then re-appear.
I just click-hold in the map and move the map some pixels.