The International Simutrans Forum

 

Author Topic: What happened to the Simutrans Forum website?  (Read 2708 times)

0 Members and 1 Guest are viewing this topic.

Offline mammothim2906 england

  • *
  • Posts: 690
  • Languages: EN
What happened to the Simutrans Forum website?
« on: February 28, 2018, 06:25:35 PM »
Hello guys. As you may be aware. The forum website went down for a bit. My question is: What happened to the Simutrans Forum website?

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #1 on: February 28, 2018, 07:08:37 PM »
It wasn't really down, at least not all the time anyway, just a lot harder to reach. Someone has noticed that the IP address changed. That may take some time to propagate as DNS servers cache it, although I'm not sure that is all there is to it.

Offline mammothim2906 england

  • *
  • Posts: 690
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #2 on: February 28, 2018, 07:10:28 PM »
Okay.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #3 on: March 01, 2018, 06:34:07 AM »
Now it's acting up again. I think it might be because isaac.panamacitypc.us is listed as one of the name servers resposible, but I can't get an IP address for it. The other listed nameserver, ns1.bluebonnetserver.com, is working, but probably only used about half the time.

Offline mammothim2906 england

  • *
  • Posts: 690
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #4 on: March 01, 2018, 12:21:55 PM »
Okay

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3594
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #5 on: March 01, 2018, 09:03:07 PM »
New server. Out of 193 websites that got copied over, 2 failed - the forum being one of them. That caused nameserver weirdness. d'oh!

The forum is now copied over after fixing the error that caused it to fail the first time.

I hand-checked more than 100 sites, so finally stopped and..... this fell through the cracks. Sorry! :(

Offline mammothim2906 england

  • *
  • Posts: 690
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #6 on: March 01, 2018, 09:32:51 PM »
Its fine

Offline IgorEliezer br

  • Devotee
  • Administrator
  • *
  • Posts: 4069
  • Cake recipes are cool.... REALLY!
    • Igor Eliezer Architect and Urban Planner/Arquiteto e Urbanista
  • Languages: PT, EN, AutoLISP, Python
Re: What happened to the Simutrans Forum website?
« Reply #7 on: March 03, 2018, 08:58:24 PM »
2 failed - the forum being one of them. (...). this fell through the cracks. Sorry! :(
That must be a wide like a hell of a crack. ;o)

Offline uci

  • *
  • Posts: 118
  • Without owner
  • Languages: EN, RO
Re: What happened to the Simutrans Forum website?
« Reply #8 on: March 05, 2018, 02:38:45 PM »
www.simutrans.com still inaccessible from my internet provider! 

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #9 on: March 05, 2018, 05:00:10 PM »
I didn't notice that site ever being inaccessible.

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3594
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #10 on: March 06, 2018, 04:59:30 AM »
It's quite possible. I've identified a couple of things that went wrong in the move; subsequently still seeing some intermitten issues and I'm struggling to find where the heck they are. :|

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #11 on: March 06, 2018, 05:53:31 AM »
I've notices that this site hardly ever loads at the first try. I tried to lookup simutrans.com, and it took 4.6 seconds on one occasion, which is surprisingly slow.

Offline uci

  • *
  • Posts: 118
  • Without owner
  • Languages: EN, RO
Re: What happened to the Simutrans Forum website?
« Reply #12 on: March 06, 2018, 03:06:33 PM »
www.simutrans.com still inaccessible from my internet provider! 
When troubleshoot I get the message:
"DNS server may be experiencing problems"

Offline Lewis

  • *
  • Posts: 98
  • Languages: EN, ES, FR, RU
Re: What happened to the Simutrans Forum website?
« Reply #13 on: March 07, 2018, 05:17:41 PM »
I get 'www.simutrans.com’s server IP address could not be found' but if I refresh that page it loads the site.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #14 on: March 07, 2018, 06:57:19 PM »
I don't see anything obviously wrong this time, except that that the site can't be found on the first try most of the time. I do find it odd that the two name servers and the site itself is on the same IP, but odd is not necessarily the same as wrong, and everything seems to work as it should when under inspection.


Update:
Remembered to do an nslookup before visiting the forum for the first time today. It timed out.
« Last Edit: March 08, 2018, 06:20:58 AM by Ters »

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3594
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #15 on: March 08, 2018, 11:02:22 AM »
I've been working on this ever since the server move. I have found various things wrong - I.... don't have a list of what on what day, alas.

Most recently, I opened a ticket with cPanel because it seemed that the old IP was appearing in various places, but it appears as of today that was only true in old log files.

They also mentioned the slow lookup and suggested that it might clear up in 48 hours propagation, which........ doesn't really make sense, but I'm weak on DNS skills. grr.

I'm opening a ticket with NameCheap to see if they can see anything on their end.

edit: Nope, but I didn't realize there were dns zones for ns1.pc2.io and nc2.pc2.io. 'A' records in there were wrong; corrected now. D'oh!
« Last Edit: March 08, 2018, 11:19:58 AM by Isaac.Eiland-Hall »

Offline uci

  • *
  • Posts: 118
  • Without owner
  • Languages: EN, RO
Re: What happened to the Simutrans Forum website?
« Reply #16 on: March 08, 2018, 11:52:39 AM »
It finally starts to work on my side. I was tired of using a proxy just to visit the forum in the past several days.

Thanks Isaac!

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9305
  • Languages: De,EN,JP
Re: What happened to the Simutrans Forum website?
« Reply #17 on: March 09, 2018, 02:16:40 AM »
I had no problem at all from Japan in the last week.

Offline DrSuperGood

  • Dev Team
  • Devotee
  • *
  • Posts: 2523
  • Languages: EN
Re: What happened to the Simutrans Forum website?
« Reply #18 on: March 09, 2018, 03:10:51 AM »
I had intermittent connectivity problems this last week. Most of the time the site would work but other times it would fail to connect, usually during the early morning in Europe (7AM-9AM).

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5366
  • Languages: EN, NO
Re: What happened to the Simutrans Forum website?
« Reply #19 on: March 09, 2018, 06:44:19 AM »
I've had no problems in the last 24 hours. I usually only had problems in the morning as well, but that may be because by then, my local DNS server had removed the entry from the previous morning from its cache.