The International Simutrans Forum

 

Author Topic: Time Interval Station Departure Junction Protecting Signal  (Read 909 times)

0 Members and 1 Guest are viewing this topic.

Offline nuhgl

  • *
  • Posts: 43
  • Languages: EN, KR, SV
Time Interval Station Departure Junction Protecting Signal
« on: April 26, 2018, 11:54:15 AM »


On Bridgewater server. Here at Manly St. Martin.
This particular trainset which has added to line most recent "Jenny Lind" often get stuck (waiting for clear) in front of a time interval station departure signal which protects a junction.  :-[

EDIT 1 Server save/load cycle fixes this issue and clear the this signal after loading cycle finishes.
This bug should be fixed. Cant reload all the time this happens.

EDIT 2



More strange thing happened after left server and reconnected to server to simulate load cycle. It did fixed and cleared that particular train above. Then now I got at same place other train behind above train who got waiting for schedule!? this line hasnt scheduled at this place. And this line is short connecting service between my company and Ves Transport.
« Last Edit: April 26, 2018, 12:11:41 PM by nuhgl »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18696
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #1 on: April 27, 2018, 08:46:15 PM »
Can I check - are either of the issues that you describe above reliably reproducible at any particular place and time on the server game?

Offline DrSuperGood

  • Dev Team
  • Devotee
  • *
  • Posts: 2709
  • Languages: EN
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #2 on: April 27, 2018, 10:56:11 PM »
The signals are generally broken at the moment. All 4 types of time interval signal are showing broken behaviour seemingly randomly...
  • Station signals randomly holding trains up "waiting for clearance" for several hours. This fits with the above example.
  • Stop signals randomly holding trains up "waiting for clearance" for several hours. This fits with the above example.
  • Platform choose signals randomly allowing 2 train to enter the same platform.
  • Distant signals not respecting the state of the assigned signal and allowing trains to pass when should be at danger or only pass at caution speed despite effectively being clear.
I cannot expand my rail network on the server as I have to devote all my play time to fixing existing trains due to the broken signals...

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18696
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #3 on: April 27, 2018, 11:51:34 PM »
I am not going to be able even to begin to try to find any problems without a reproduction case for each specific issue, and please, as is made clear in the forum rules, no more than one specific bug report for each thread: it makes it impossibly difficult to keep a track of bug reports otherwise.

Offline nuhgl

  • *
  • Posts: 43
  • Languages: EN, KR, SV
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #4 on: April 28, 2018, 08:53:36 AM »
Can I check - are either of the issues that you describe above reliably reproducible at any particular place and time on the server game?

Hello James,

Yes this can reproduce at any time, New locomotive Jenny Line with same carriage set is assigned to Bay Mainline at the southern depot at Manly St. Martin Station, and scheduled to begin its schedule at that particular platform toward north. Then this Jenny Line new locomotive train set will be stuck behind at any time interval stop signal which acts as station departure signal which protecting junction.

It never get stuck behind any other stop signals / station signals that do not protect junction.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18696
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #5 on: May 02, 2018, 12:01:11 AM »
I think that this is the same as the issue reported in another thread, which I believe that I have fixed. Would you be able to re-test with to-morrow's nightly build? I should be most grateful.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18696
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Time Interval Station Departure Junction Protecting Signal
« Reply #6 on: June 05, 2018, 06:59:10 PM »
Can I check whether this can still be reproduced?