The International Simutrans Forum

 

Author Topic: [r8447] Focus code is broken  (Read 329 times)

0 Members and 1 Guest are viewing this topic.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2836
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
[r8447] Focus code is broken
« on: May 20, 2018, 09:43:32 PM »
As I'm doing the new theme I noticed that the focus code is broken.

Steps 1
  • Open a rail depot
  • Click on the scrollbar at the top

Expected
The scrollbar skin changes.

Actual
The scrollbar skin remains the same.


Steps 2
  • Open the line management window
  • Add some lines to the list
  • Select one of the lines
  • Focus another window

Expected
The selection colours change when the other window has the focus.

Actual
The selection remains with the same colours.
« Last Edit: May 20, 2018, 11:14:03 PM by An_dz »

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4494
  • Languages: EN, DE, AT
Re: [r8447] Focus code is broken
« Reply #1 on: May 28, 2018, 06:26:55 PM »
I do not understand. Why would you expect the selection colour to change when out of focus?

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2836
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: [r8447] Focus code is broken
« Reply #2 on: May 28, 2018, 06:35:28 PM »
Mostly because it used to, even before the theme patch.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4494
  • Languages: EN, DE, AT
Re: [r8447] Focus code is broken
« Reply #3 on: May 28, 2018, 08:35:01 PM »
I tried to fix it in r4781. Now the list is focusable again and can be navigated by arrow keys.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2836
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: [r8447] Focus code is broken
« Reply #4 on: May 29, 2018, 07:41:57 PM »
Cool. But the list focus is strange as when you open the window I can't move it as it moves the map and when I put focus on it I can't lose it to move the map.