The International Simutrans Forum

 

Author Topic: not accept servers  (Read 1113 times)

0 Members and 1 Guest are viewing this topic.

Offline kittens45

  • *
  • Posts: 51
not accept servers
« on: June 25, 2018, 02:18:57 AM »
Every time I try to access servers, it says my pack is mismatched

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: not accept servers
« Reply #1 on: June 25, 2018, 04:26:53 AM »
Well, is it mismatched? Kind of low on details here. What's the version?

Offline DrSuperGood

  • Dev Team
  • Devotee
  • *
  • Posts: 2709
  • Languages: EN
Re: not accept servers
« Reply #2 on: June 25, 2018, 04:37:28 AM »
Tried using my java Simutrans Extended updater? It should be a 1 click solution to making sure the pakset and executable are always up to date with the most recent nightly (used by servers).
« Last Edit: June 25, 2018, 04:51:42 AM by DrSuperGood »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #3 on: June 25, 2018, 09:19:11 AM »
Every night, the pakset and the executable update to the latest version automatically. You will need to download the latest versions in order to play if there have been any changes from the previous day. Dr. Supergood's Java updater can do this for you semi-automatically (you have to invoke the tool, but it will work automatically after that).

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #4 on: June 25, 2018, 08:37:52 PM »
where do it download it

Offline Rollmaterial fi

  • Devotee
  • *
  • Posts: 567
  • Languages: EN, FR, DE, FI, SE

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #6 on: June 26, 2018, 03:51:36 PM »
now I'm getting fatal error- out of memory or other error allocating new object

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #7 on: June 26, 2018, 04:37:56 PM »
In that case, I suggest that you download the 64-bit version of the executable rather than the 32-bit version, as the 64-bit version can use more memory than can the 32-bit version.

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #8 on: June 26, 2018, 06:58:03 PM »
now track ins taking a long to build

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #9 on: June 26, 2018, 09:17:20 PM »
Do you mean that there is a delay between the time at which you execute the command to build things and the time at which things are actually built?

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #10 on: June 26, 2018, 09:19:33 PM »
yes

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #11 on: June 26, 2018, 09:38:59 PM »
This is because your computer is not running fast enough to keep up with the server. To help to alleviate this problem, you can disable the water animation (look in the display settings dialogue) and zoom in more closely. These things help because the graphics in Simutrans do not use hardware acceleration and thus rely on the CPU, which reduces the CPU time available for the simulation calculations.

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #12 on: June 27, 2018, 12:08:55 AM »
don't see disable water animation on display dialog

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #13 on: June 27, 2018, 09:39:06 AM »
My apologies: I misremembered where the setting is located. You need to use the advanced settings dialogue: press the "i" key, navigate to the "display" tab and set "water animation ms" to 0.

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #14 on: June 27, 2018, 10:57:46 PM »
the i key method dosn't work in server mode

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #15 on: June 27, 2018, 11:22:53 PM »
In which case, you will need to edit simuconf.tab (the base version, not the pakset version): change water_animation_ms = 250 to water_animation_ms = 0.

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #16 on: June 28, 2018, 03:21:53 AM »
tried it still didn't work

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #17 on: June 28, 2018, 07:07:14 AM »
The water is still animated?

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #18 on: June 28, 2018, 12:26:28 PM »
yes and still going slow

Offline Rollmaterial fi

  • Devotee
  • *
  • Posts: 567
  • Languages: EN, FR, DE, FI, SE
Re: not accept servers
« Reply #19 on: June 28, 2018, 12:34:25 PM »
In which folder is the simuconf.tab you modified?

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #20 on: June 28, 2018, 12:56:03 PM »
main config folder
« Last Edit: June 28, 2018, 08:59:45 PM by kittens45 »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18679
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: not accept servers
« Reply #21 on: June 30, 2018, 10:54:44 AM »
You can disable the water animation in a server game by using the advanced settings dialogue ("i" key) as described above before joining the server game.

Offline kittens45

  • *
  • Posts: 51
Re: not accept servers
« Reply #22 on: June 30, 2018, 12:17:34 PM »
tried that