The International Simutrans Forum

 

Author Topic: TileCutter 1.1.0  (Read 2231 times)

0 Members and 1 Guest are viewing this topic.

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2873
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
TileCutter 1.1.0
« on: July 25, 2018, 11:37:05 PM »


New version is out, now with full season support, no more warnings for ICCP profiles and fixing TCP projects not saving.

You can choose any combination of seasons, if you enable any of autumn, winter, spring or a combination of them and also leave either autumn, winter, spring or a combination of them disabled, those disabled will have summer season graphics.

Known issue
Console works but doesn't output messages.

Reporting bugs
You can submit a bug report by posting a reply to this thread or on GitHub with the following information:

1. Clear steps on how to trigger it
2. tilecutter.log and TileCutter.exe.log (if present) - These can be found under "%USERPROFILE%\Application Data\tilecutter\" on Windows, "~/Library/Logs/tilecutter.log" on OSX and "~/.tilecutter/tilecutter.log" on all other platforms.

Download
If upgrading from any version before 1.0 it's advisable to completely delete the old version instead of replacing the files.

Windows executable is stand-alone. Other platforms must download the dependencies (Python 3 & wxPython 4).

Windows version needs the Visual C++ Redistributable 2010 x64. The latest version of the 2010 version is 10.0.40219, and you can download the x64 version here.

https://github.com/An-dz/tilecutter/releases/

Future
There are planned features that you can check out on GitHub.

Thanks to Ashley Baldock, the original creator, for all the work and for letting me use the same name. This tools is a time-saver.

Offline NNW

  • *
  • Posts: 72
  • Languages: EN,DE,AT
Re: TileCutter 1.1.0
« Reply #1 on: June 29, 2019, 07:48:20 AM »
I get an error with the "Linux" Version:File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk3/wx/_core.py", line 12003, in Append
    return _core_.Menu_Append(*args, **kwargs)
TypeError: in method 'Menu_Append', expected argument 2 of type 'int'

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2873
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: TileCutter 1.1.0
« Reply #2 on: June 29, 2019, 06:23:29 PM »
You're using python 2 and wxPython 3, TileCutter is now using Python 3 and wxPython 4 since v1.

I've forgotten to add a shebang to tell it must use Python 3. You can either run tilecutter with python3 tilecutter.pyw or add this as the first line of tilecutter.pyw: #!/usr/bin/env python3.

Offline NNW

  • *
  • Posts: 72
  • Languages: EN,DE,AT
Re: TileCutter 1.1.0
« Reply #3 on: June 30, 2019, 09:25:04 AM »
God thanks, that I'm not using Linux for the first time.
I have altered
Code: [Select]
python tilecutter.pyw to
Code: [Select]
python3 tilecutter.pywAnd now it works lol

Offline NNW

  • *
  • Posts: 72
  • Languages: EN,DE,AT
Re: TileCutter 1.1.0
« Reply #4 on: July 14, 2019, 08:44:39 AM »
Houston I have another problem hihi. TC removes the Alpha channel from the images and creates on with a solid black background. This does not work with ST ;)
I'm using PovRay with the +UA switch for my objects....

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2873
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: TileCutter 1.1.0
« Reply #5 on: July 14, 2019, 10:48:15 PM »
Please send me your TileCutter log and a testing image.

Offline NNW

  • *
  • Posts: 72
  • Languages: EN,DE,AT
Re: TileCutter 1.1.0
« Reply #6 on: July 18, 2019, 04:29:25 PM »
Template is attached