The International Simutrans Forum

 

Author Topic: What happened to the running_cost_increase config option, or, how do I  (Read 271 times)

0 Members and 1 Guest are viewing this topic.

Offline Junna

  • Devotee
  • *
  • Posts: 1068
disable the obsolences increase in running cost? I'm sure there used to be a setting for this in the config some time ago...

Offline Ranran jp

  • *
  • Posts: 115
  • Languages: ja
Re: What happened to the running_cost_increase config option, or, how do I
« Reply #1 on: October 05, 2018, 09:47:41 AM »
Add the following line to simuconf.tab :thumbsup:

Code: [Select]
obsolete_running_cost_increase_percent = 100

Offline Junna

  • Devotee
  • *
  • Posts: 1068
Re: What happened to the running_cost_increase config option, or, how do I
« Reply #2 on: October 05, 2018, 06:07:37 PM »
Ah, this was the one I seemed to remember. It doesn't seem to still work, however? It makes no difference on the running cost increase.

Offline Ranran jp

  • *
  • Posts: 115
  • Languages: ja
Re: What happened to the running_cost_increase config option, or, how do I
« Reply #3 on: October 06, 2018, 02:36:32 AM »
It's still working. If you want to apply changes in already started games, you need to change the value of progdir_overrides_savegame_settings to 1 and reboot Simutrans.

Note that this does not apply to vehicles which increase_maintenance_by_percent is set individually in dat file. However, such vehicles rarely exist in pak128.Britain-EX except for some carts.