The International Simutrans Forum

 

Author Topic: weird behavior on signal after choose signal.  (Read 222 times)

0 Members and 1 Guest are viewing this topic.

Offline Vladki cz

  • Devotee
  • *
  • Posts: 2450
    • My addons, mostly roadsigns
  • Languages: EN, CS
weird behavior on signal after choose signal.
« on: October 22, 2018, 07:43:54 PM »
I have noticed that the signal ahead of choose signal shows temporarily clear aspect, even though the track ahead is not reserved. When the train approaches to 4 tiles, it turns back to danger. Is that intentional?
See the attached screenshot.

The behavior happens only if the train is scheduled to stop there, and it does not matter if it chooses the scheduled or alternate platform.
If the train passes through without stopping, the next signal behaves normally, i.e. is at danger until the train approaches to 4 tiles, when it reserves track further and turns to clear.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4533
  • Languages: EN, DE, AT
Re: weird behavior on signal after choose signal.
« Reply #1 on: October 23, 2018, 06:11:42 AM »
The signal is on the last tile of the current route of the train. Maybe this is the reason?

Offline Vladki cz

  • Devotee
  • *
  • Posts: 2450
    • My addons, mostly roadsigns
  • Languages: EN, CS
Re: weird behavior on signal after choose signal.
« Reply #2 on: October 23, 2018, 06:21:58 AM »
Could be. But it behaves normally if there is no choose signal in rear.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9353
  • Languages: De,EN,JP
Re: weird behavior on signal after choose signal.
« Reply #3 on: October 23, 2018, 07:43:27 AM »
The block reserver has a list where it adds all signal on the route (since they are all green if successful). But it added also signals on the last tile. Fixed in r8617. It did not affect functionality, it is just optics.