The International Simutrans Forum

 

Author Topic: Bug: Month record of "transported goods" is incorrect  (Read 551 times)

0 Members and 1 Guest are viewing this topic.

Offline Ranran jp

  • *
  • Posts: 396
  • Languages: ja
Bug: Month record of "transported goods" is incorrect
« on: December 31, 2018, 12:58:01 AM »
I think the "Goods needed" chart in the City list dialog is broken.
(I posted here but, the identity of "Good needed" seems to be transported goods in this chart.)

I noticed that there is no correlation between "Years" and "Months" in this chart.


The above image is in demo.sve. Probably since it used to function properly in the past, records of "months" remain.

However, when I fast forwarded with the current version extended, it continue to show 0.


Contrary to this, the value of "Years" will increase.
« Last Edit: February 04, 2019, 03:19:39 PM by Ranran »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18502
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Bug: Month record of "transported goods" is incorrect
« Reply #1 on: January 01, 2019, 11:45:53 AM »
Thank you for the report. I think that I am going to have to wait until I get back home and can easily use a graphical debugger before looking into this one.

Offline Ranran jp

  • *
  • Posts: 396
  • Languages: ja
Re: Bug: Month record of "transported goods" is incorrect
« Reply #2 on: January 28, 2019, 02:56:44 PM »
I think I fixed this bug.
I threw a pull request, so please check it.
(Again note that this data is "Goods transported", not "Goods needed")

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18502
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Bug: Month record of "transported goods" is incorrect
« Reply #3 on: January 28, 2019, 10:02:42 PM »
Thank you very much for this: now incorporated.

My apologies for not having had a great deal of time to spend on Simutrans of late.

Offline Ranran jp

  • *
  • Posts: 396
  • Languages: ja
Re: Bug: Month record of "transported goods" is incorrect
« Reply #4 on: February 04, 2019, 03:22:44 PM »
Sorry for the late report but I confirmed that this bug has been fixed in #e24449c.