The International Simutrans Forum

 

Author Topic: [r8700] New Game/Settings/Default seemingly appended but it isn't  (Read 290 times)

0 Members and 1 Guest are viewing this topic.

Offline captain crunch

  • *
  • Posts: 111
Pressing the "Simuconf.tab" or "Default" buttons in the New Game / Settings dialogue appends the defaults to the list of the current settings instead of replacing them. This additional set of settings is forgotten when the dialogue is closed.
This means that it is possible to change the settings, but it is impossible to load "simuconf.tab" or reset them to the defaults.
To reproduce the error:
- press "New Game" button
- press "Settings" button
- press "Simuconf.tab" and/or "Default" buttons

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4555
  • Languages: EN, DE, AT
Re: [r8700] New Game/Settings/Default seemingly appended but it isn't
« Reply #1 on: March 04, 2019, 05:38:13 PM »
should work with r8701 again. Thanks for the reports!

Offline captain crunch

  • *
  • Posts: 111
Re: [r8700] New Game/Settings/Default seemingly appended but it isn't
« Reply #2 on: March 05, 2019, 11:59:10 AM »
Yes, r8701 works somewhat better, but:
a) Pressing "Simuconf.tab" changes the left margin of settings' descriptions.
b) When a setting is changed and then the "Simuconf.tab" button is pressed the program can exit with segmentation fault.
c) When a setting is changed and then the "Default" button is pressed the programm will exit with segmentation fault.

case (c) when simutrans run in gdb:
Code: [Select]
Reading simuconf.tab successful!

Thread 1 "sim" received signal SIGSEGV, Segmentation fault.
0x00005555556d190c in gui_container_t::get_focus() ()
(gdb) where
#0  0x00005555556d190c in gui_container_t::get_focus() ()
#1  0x00005555556da8ab in gui_numberinput_t::init(int, int, int, int, bool, unsigned short) ()
#2  0x00005555557812f0 in settings_general_stats_t::init(settings_t const*) ()
#3  0x00005555557741e0 in settings_frame_t::action_triggered(gui_action_creator_t*, value_t) ()
#4  0x00005555556cd2ff in button_t::infowin_event(event_t const*) ()
#5  0x00005555556d205c in gui_container_t::infowin_event(event_t const*) ()
#6  0x00005555556d205c in gui_container_t::infowin_event(event_t const*) ()
#7  0x00005555557154d0 in gui_frame_t::infowin_event(event_t const*) ()
#8  0x0000555555788f46 in check_pos_win(event_t*) ()
#9  0x00005555558efa10 in simu_main(int, char**) ()
#10 0x00005555559070d9 in sysmain(int, char**) ()
#11 0x00007ffff68612e1 in __libc_start_main (main=0x5555556008f0 <main>,
    argc=1, argv=0x7fffffffe208, init=<optimized out>, fini=<optimized out>,
    rtld_fini=<optimized out>, stack_end=0x7fffffffe1f8)
    at ../csu/libc-start.c:291
#12 0x000055555560092a in _start ()
(gdb)

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4555
  • Languages: EN, DE, AT
Re: [r8700] New Game/Settings/Default seemingly appended but it isn't
« Reply #3 on: March 05, 2019, 04:23:54 PM »
should be fixed in r8704/05.

Offline captain crunch

  • *
  • Posts: 111
Re: [r8700] New Game/Settings/Default seemingly appended but it isn't
« Reply #4 on: March 06, 2019, 11:27:15 AM »
should be fixed in r8704/05.
It works! Thanks alot!