The International Simutrans Forum

 

Author Topic: Carriage return issues  (Read 967 times)

0 Members and 1 Guest are viewing this topic.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Carriage return issues
« on: April 14, 2019, 05:44:48 PM »
I notice that, when using the standard editor (i.e., when "Toggle view" has not been selected), it often happens that double carriage returns are not respected as such, with the result that breaks between paragraphs inserted for formatting purposes disappear and the text is harder to read. I have noticed this for some time, but have not got around to reporting this until now.

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3659
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Carriage return issues
« Reply #1 on: April 19, 2019, 04:01:56 AM »
I'll see if I can poke at this, but delving into SMF's code doesn't give me hope for a solution. :(

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2908
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: Carriage return issues
« Reply #2 on: April 29, 2019, 12:04:46 AM »
By standard do you mean the WYSIWYG editor or the plain text one?

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Carriage return issues
« Reply #3 on: April 30, 2019, 11:04:07 AM »
By standard do you mean the WYSIWYG editor or the plain text one?

I mean the one that is selected by default when clicking "reply", i.e., the WYSIWYG editor.

Offline Leartin at

  • Devotee
  • *
  • Posts: 1269
  • PAK-DEV P192C
  • Languages: DE, EN
Re: Carriage return issues
« Reply #4 on: April 30, 2019, 01:24:37 PM »
For completions sake: Whether it's WYSIWYG or not by default is a setting in the users profile, so "the default" is not quite a helpful description :)

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2908
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: Carriage return issues
« Reply #5 on: May 06, 2019, 01:59:57 AM »
Exactly what Leartin said, I was not clear enough. I wanted to know if the bug happens when going plain -> WYSIWYG or WYSIWYG -> plain.

But now I see that it's WYSIWYG -> plain.



Fixed. It uses an HTML5 feature called contenteditable and it has no standard on its output. SMF was outputting Firefox-like html on WebKit/Blink and also got it wrong on how to transform it back to plain text on WebKit/Blink.
« Last Edit: May 06, 2019, 04:32:49 AM by An_dz »

Offline Carl

  • Devotee
  • *
  • Posts: 1602
    • Website
  • Languages: EN
Re: Carriage return issues
« Reply #6 on: August 07, 2019, 01:06:24 PM »
Just came to this forum to post a similar bug. The following post appears to have paragraph breaks in the WYSIWYG editor but these don't appear in the post:
https://forum.simutrans.com/index.php/topic,7367.msg181291.html#msg181291


I also had terrible trouble formatting this post the other day - after having done it in WYSIWYG I first ended up with no line breaks at all - and it didn't match the preview.
https://forum.simutrans.com/index.php/topic,7367.msg181252.html#msg181252

Is the solution just not to use the WYSIWYG editor?

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2908
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: Carriage return issues
« Reply #7 on: August 07, 2019, 08:35:37 PM »
Yes, not using the WYSIWYG editor will yield no problems, I never used it.