The International Simutrans Forum

 

Author Topic: Can't install Simutrans on Linux  (Read 634 times)

0 Members and 1 Guest are viewing this topic.

Offline astrog

  • *
  • Posts: 2
  • Languages: EN, ES
Can't install Simutrans on Linux
« on: June 28, 2019, 01:04:46 AM »
Hi. I feel very embarrassed about having to ask for help, but for the life of me I can't figure out how to run Simutrans. I downloaded the latest linux version from Sourceforge but I have no idea what do do with it. So I tried installing the apt-get version but I got a six year old one and that will not do.

Sooo, after I downloaded and extracted the sourceforge file... then what? What's the ELF file? What am I supposed to run? Please keep in mind I'm an inexperienced Linux user.

Thanks,

Offline An_dz

  • Web Admin
  • Administrator
  • *
  • Posts: 2908
  • D'oh
    • by An_dz
  • Languages: pt, en, it, (de)
Re: Can't install Simutrans on Linux
« Reply #1 on: June 28, 2019, 05:20:58 AM »
I've split you question on a Help request because the original topic was super old.

The current file in Sourceforge is broken and is missing the executable. You can either upgrade your Ubuntu to the latest stable release (19.04 disco) that includes the latest Simutrans version or you can download the package manually. Though I highly recommend upgrading Ubuntu.

Offline Vladki cz

  • Devotee
  • *
  • Posts: 2735
    • My addons, mostly roadsigns
  • Languages: EN, CS
Re: Can't install Simutrans on Linux
« Reply #2 on: June 28, 2019, 06:42:51 AM »
ELF is the linux executable format. It just doesn't have any extension.