News:

Simutrans Tools
Know our tools that can help you to create add-ons, install and customize Simutrans.

Images of vehicles no longer appear in "message center"

Started by Yona-TYT, July 14, 2019, 03:48:28 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Yona-TYT



The image of the vehicles should appear when you open a message of: New vehicle now available: "vehicle name"

I was testing the scenario tutorial, and I noticed this error, I guess it was when I updated the code of the gui.

Dwachs

Which version/revision of the program is affected?
Parsley, sage, rosemary, and maggikraut.


Dwachs

Parsley, sage, rosemary, and maggikraut.

Yona-TYT

Quote from: Dwachs on July 20, 2019, 09:46:43 AM I cannot reproduce this
Quote from: Dwachs on July 20, 2019, 09:46:43 AM I cannot reproduce this
It seems that the first 6 or 7 messages on the list show the images correctly, the rest do not


Yona-TYT

Now I can replicate the problem!

It turns out that if the message is opened for the first time, the image of the vehicle appears normally.

To replicate save the game, load savegame again and when opening the message the image is no longer displayed.

Edit.
The error is that the message is duplicated when the game is saved and loaded again.

Dwachs

Saving & reloading messages loses the information about image. This is hard to fix.
Parsley, sage, rosemary, and maggikraut.

Yona-TYT

I have saved and loaded a savegame 10 times, and the result was 10 messages repeated in the "message center".  :o :o :o :o

Savegame: https://www.mediafire.com/file/7qts42tkl5znnv2/replicate.sve/file


prissi


Ters

When you load a game, generation of all timeline related messages valid for the current month will be triggered. So if you save and load a game nine times during a single game month, you get ten messages. Nice to have in case the month changed right before you saved. Otherwise, one might miss them. Especially if using autosave on close.