The International Simutrans Forum

 

Author Topic: Electrification of tunnel portal not possible  (Read 410 times)

0 Members and 1 Guest are viewing this topic.

Offline Freahk

  • *
  • Posts: 215
  • Languages: DE, EN
Electrification of tunnel portal not possible
« on: October 12, 2019, 11:20:35 AM »
Sorry, my bad.
I reloaded the old save, to inspect this again and there was a public way on my tunnel portal. Didn't see it because I just checked for the tunnel portal, not the rail on it.

However, it is kind of strange and confusing that the player can destruct his own tunnel portal with public rail on it using the "Destroy/remove" tool but not by using the "remove railway tracks" tool.
Also, maybe any player should be able to electrify public rails.


Hey there,
I have encountered a strange bug where electrification of rail tunnel portals will fail with "ways not connected"
However, ways are definitely connected, as my steam trains used it for years without any problems and still do so. Also, it's not some kind of glitchy diagonal tunnel portal or something like that but just an ordinary straight tunnel portal, see the attachment for this.
There is yet another problem with this tunnel portal. I can't remove it using the way removal tool. The only way to remove it is by disconecting it in the tunnel, so I don't have to remove the whole tunnel, and use the generic destroy/remove tool.

As always, I will come back to this if I can create a small reproduction case for this some day.

Destroying and rebuilding the tunnel portal fixed the problem.
« Last Edit: October 12, 2019, 12:15:02 PM by Freahk »