News:

Use the "Forum Search"
It may help you to find anything in the forum ;).

[Solution] No MIDI music on GNU/Linux

Started by Roboron, August 27, 2020, 06:28:16 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Roboron

I've been suffering this problem for years, and none of the solutions proposed here on the forums worked. I had lost all hope. However, recently I found a Japanese post about this problem, which offers a working solution. TLDR:


  • Compile Simutrans with mixer_sdl2
  • Install fluidsynth (I've tried with timidity++, with no luck)
  • Install a soundfont
  • Open Simutrans with SDL_SOUNDFONTS=/path/to/soundfont variable set

I get some ALSA complains, but nothing that prevents the music from playing. The downside is that Simutrans will take significantly more time to startup. But I finally got to listen the Simutrans music  :D

P.D.: I've updated my Arch Linux packages to compile against sd2_mixer, change the timidity dependency to fluidsynth, and display this information after installing the game.