News:

Simutrans Tools
Know our tools that can help you to create add-ons, install and customize Simutrans.

Crashing on startup, fresh install Mint 20.04 (ubuntu) + version 120.4.1 build 1

Started by buggy, October 22, 2020, 11:47:54 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

buggy

I have installed Simutrans on my freshly installed linux mint xfce 20.04. when simutrans starts it is loadking the pak64 and then asks the preferred language. After that I see "distributing factories and a crash.

I installed also the pak64 and simutrans-data. I also tried adding simutrans-data, but the same thing happens. I did this through synaptic, so all  the dependencies should be fine.
The systems error logs show:
13:06:00 systemd-coredum: Process 2545 (simutrans) of user 1000 dumped core.

Stack trace of thread 2545:
#0  0x00007fb49e5e1e4c __memcpy_ssse3 (libc.so.6 + 0x16ae4c)
#1  0x00005570809fb78d n/a (simutrans + 0x38578d)
#2  0x000055708082d0ff n/a (simutrans + 0x1b70ff)
#3  0x82962c0168002c00 n/a (n/a + 0x0)

13:06:00 systemd-coredum: Process 2545 (simutrans) of user 1000 dumped core.

Stack trace of thread 2545:
#0  0x00007fb49e5e1e4c __memcpy_ssse3 (libc.so.6 + 0x16ae4c)
#1  0x00005570809fb78d n/a (simutrans + 0x38578d)
#2  0x000055708082d0ff n/a (simutrans + 0x1b70ff)
#3  0x82962c0168002c00 n/a (n/a + 0x0)

I am a newbie with Linux, so I don know if I could find any fiurther information...
I have no desire to install through steam . Any help is appreciated! Thank you

UPDATE
I completely removed  the installation with synaptic and added the german repo (see [rul="https://www.simutrans-germany.com/wiki/wiki/en_Simutrans_repo_deb?page_ref_id=1802here[/url]. I could install version 1.22. And the same thing happened again. I don have any clue what I can do to find out whatś going wrong.

Matthew

The latest Linux Mint XFCE uses the Ubuntu 20.04 repositories, which are still on Simutrans 120.4:



(This doesn't solve your problem, but might be useful info for others investigating)
(Signature being tested) If you enjoy playing Simutrans, then you might also enjoy watching Japan Railway Journal
Available in English and simplified Chinese
如果您喜欢玩Simutrans的话,那么说不定就想看《日本铁路之旅》(英语也有简体中文字幕)。

Andarix

install SDL2-Version

SDL mixer/SDL2 mixer does not work on Ubuntu 20.04 and Linux systems derived from it

buggy

Thanks for your replies! Using synaptic automatically gets me 120.4 in my case with linux mint. But also the newer 122 did not solve the problem.
I the meantime I solved the problem. I still don get how, but it seems to be the bug described here:

It seems indeed (I was typing my message while you added yours Andarix) it is the same bug described here: https://forum.simutrans.com/index.php/topic,20154.0.html

What solved it for me was:
a) adding the German repository as described here: https://simutrans-germany.com/wiki/wiki/en_Simutrans_repo_d
b) uninstall the previous version and
c) instal the following package: simutrans-uni-sdl2 . (it will automatically indicate that pak and data need to be added too)


Roboron

Quote from: Andarix on October 22, 2020, 01:32:43 PMSDL mixer/SDL2 mixer does not work on Ubuntu 20.04 and Linux systems derived from it

Mmm, the version I put on Steam is using sdl2_mixer, and it does works on Ubuntu 20.04. But I compiled Simutrans on Debian, and I also included libSDL2_mixer-2.0.so.0 from Debian Buster. So, the problem probably is with Ubuntu versio of sdl2_mixer...

What a mess. One more reason to drop sdl2_mixer with fluidsynth, I need to get back to work on this asap.

P.D.: Are Ubuntu maintainers even testing their packages? (I guess not, they just copy the work done on Debian lol)