The International Simutrans Forum

 

Author Topic: Furniture factory output  (Read 2665 times)

0 Members and 1 Guest are viewing this topic.

Offline sanna

  • *
  • Posts: 234
Furniture factory output
« on: July 13, 2009, 09:14:04 PM »
I started playing a pakBritain game in 1930, got a Furniture Factory (FurnitureFactory1920 according to log) which I eventually got around to supplying with planks. However, the furniture factory produces furniture at an extremely slow rate (just a few pallets a month).

Looking closer at the factory details both consumption and production is shown as 1%

It is most likely related (according to experts consulted on IRC *smile*) to:
Code: [Select]
InputFactor[0]=2 and OutputFactor[0]=2
Is this slow rate intentional?

Offline The Hood

  • Moderator
  • *
  • Posts: 2889
  • pak128.Britain developer
Re: Furniture factory output
« Reply #1 on: July 13, 2009, 09:39:24 PM »
Looks like a mistake to me - thanks for the spot...

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18564
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Furniture factory output
« Reply #2 on: July 14, 2009, 04:25:27 PM »
Oops - that'll be my fault again... sorry. *Hits self with trout*.

I'll have to try to fix that this evening... Thank you very much for reporting the fault :-)

Online wlindley us

  • Devotee
  • *
  • Posts: 961
    • Hacking for fun and profit since 1977
  • Languages: EN, DE
Inefficient Furniture Plants
« Reply #3 on: July 16, 2009, 03:00:45 PM »
In 1.0.2, the Furniture Factory turns 100 units of Planks into one unit of Furniture?

Planks are very condensed wood, while furniture contains lots of air, even after shaving off a fair amount as sawdust, so this doesn't seem to be quite sensible.

It also means your furniture trains or trucks won't ever have very much to do!

Perhaps a 1-to-1 ratio is more sensible?

Offline The Hood

  • Moderator
  • *
  • Posts: 2889
  • pak128.Britain developer
Re: Inefficient Furniture Plants
« Reply #4 on: July 16, 2009, 03:21:19 PM »
Thanks for the report.  This bug has already been picked up and will be fixed in the next release - merging this topic.