The International Simutrans Forum

 

Author Topic: [unconfirmed] [102-2-1] -freeplay not recognized  (Read 2770 times)

0 Members and 1 Guest are viewing this topic.

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3659
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
[unconfirmed] [102-2-1] -freeplay not recognized
« on: December 11, 2009, 06:46:16 PM »
Testing in progress, but it appears that "-freeplay" doesn't work - I have a shortcut with this enabled, just as it has always worked before, but bankruptcy was triggered in pak.German (all paks downloaded from the download page, i.e. latest to match 102-2-1).

I'm trying to trigger this again using other methods (paks, cmd starting of simutrans) to see if I can replicate it or see if it's some other problem, but I figured I'd post this in case any other players had this experience as well...

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: [unconfirmed] [102-2-1] -freeplay not recognized
« Reply #1 on: December 16, 2009, 06:32:03 AM »
could not reproduce it.

Offline whoami

  • Devotees (Inactive)
  • *
  • Posts: 693
Re: [unconfirmed] [102-2-1] -freeplay not recognized
« Reply #2 on: December 28, 2009, 12:19:16 AM »
it appears that "-freeplay" doesn't work
I can confirm this for the same setup and versions as Isaac wrote (102.2.1 with Pak.German, Win-GDI without debugging). The option in the players dialog works, however.
If it is intended, then the Wiki and other documentation need to be updated.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9565
  • Languages: De,EN,JP
Re: [unconfirmed] [102-2-1] -freeplay not recognized
« Reply #3 on: December 28, 2009, 03:41:01 PM »
I think the pak set specific setting overwrites the command line in this case. will investigate.