The International Simutrans Forum

 

Author Topic: [solved] Constant crashing attempting underground/elevated construction  (Read 7165 times)

0 Members and 1 Guest are viewing this topic.

Offline Junna

  • Devotee
  • *
  • Posts: 1080
I'm having constant crashes when attempting to build underground (straight tunnels work fine but building them by oneself causes crashes) and anything that is elevated (the monorail as well as anything based thereupon like elevated roadways). Occasionally it is possible to build sections of underground/elevated way, but eventually it will crash. There are seemingly regions of a map where it is more or less likely to crash, though this seems to constantly change with any subsequent loading so it impossible to know. Sometimes it will crash immediately when moving it a single tile.

The crashes are of the exception error kind, I am not sure how one would go about viewing any logs as the program closes after one clicks the window away. I suspected at first that this was due to some of the custom paks used, but resorting to a clean install (I think anyway, but as good as) with vanilla pak 128 and nothing added gives the same results. I also thought that it might be something to do with me using Experimental, but trying the same things in standard also has the same result.

I guess maybe the solution might be very simple and I've been looking far too much into it, but I am confused as to how one should proceed. The constant crashing makes it so that constructing even a rudimentary elevated or underground way can take up to an hour of constantly restarting simutrans and trying again. A lot of experimenting with this behaviour has given no clues as to how and why it occurs, and no particular things seem to trigger it; it can work one time, and crash the other. Any help would be much appreciated.
« Last Edit: December 18, 2009, 04:36:36 AM by Isaac.Eiland-Hall »

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3651
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Constant crashing attempting underground/elevated construction
« Reply #1 on: December 15, 2009, 11:23:45 PM »
Well, of course we would hope to see crashes fixed. :)

May I ask what version of Simutrans?

Also, welcome to the forum! :-)

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #2 on: December 15, 2009, 11:56:27 PM »
May I ask what version of Simutrans?


102.1 and 102.2, and experimental 6.6 and 7.0.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4587
  • Languages: EN, DE, AT
Re: Constant crashing attempting underground/elevated construction
« Reply #3 on: December 16, 2009, 06:27:49 AM »
Thank you for the report. However, I could not reproduce it.

Did you try version 102.2.1:

http://forum.simutrans.com/index.php?topic=3920.msg38442#new

?

Which OS do you have (Windows, Linux etc)?

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #4 on: December 16, 2009, 06:53:50 AM »
Tried 102.2.1, and it happens all the same. Building in underground mode, it eventually crashes. And this is with a pure pak 128 1.4.5, though it seems to take a bit longer to crash without custom paks.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4587
  • Languages: EN, DE, AT
Re: Constant crashing attempting underground/elevated construction
« Reply #5 on: December 16, 2009, 07:09:26 AM »
Strange. Are you on Linux?

Could you try to run simutrans in a debugger?

E.g. gdb ./sim, then "r". After the crash "bt" (backtrace).

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #6 on: December 16, 2009, 07:15:19 AM »
Strange. Are you on Linux?

Could you try to run simutrans in a debugger?

E.g. gdb ./sim, then "r". After the crash "bt" (backtrace).

I'm on Windows XP. How would I go about run that in a debugger?

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Constant crashing attempting underground/elevated construction
« Reply #7 on: December 16, 2009, 08:36:07 AM »
It would be of tremedous help if you could post a saved game, saves a lot of guess work.

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: Constant crashing attempting underground/elevated construction
« Reply #8 on: December 16, 2009, 10:30:56 AM »
Depends... if you're savvy enough and content with having to spend time, you can install mingw and do the same on windows.

(savvy = capable of unzipping stuff, setting variables, using command line)

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #9 on: December 16, 2009, 02:21:40 PM »
It would be of tremedous help if you could post a saved game, saves a lot of guess work.

What would a save game tell? This happens with newly created games and everything so I'm not sure it would tell anything. It does happen more frequently with later highly developed games however. Most of the games I play regularly have so much custom paks so it would be useless to post them.

Offline Diegote

  • *
  • Posts: 140
Re: Constant crashing attempting underground/elevated construction
« Reply #10 on: December 16, 2009, 04:14:48 PM »
I tested version 102.2.1 (Win pak128, new games and saved games) and I got some random CTD:

1) build a tunnel under water



2) Zoom out 2 or 3 (I do not know if this is important)
3) buil some road section ('Road tunnel' tool) in 'sliced underground mode' (level -3), building it as in the picture:



In some tests I've layed many road sections (30+) and no crashes, in other I have built a couple of sections and the game crash.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4587
  • Languages: EN, DE, AT
Re: Constant crashing attempting underground/elevated construction
« Reply #11 on: December 16, 2009, 04:59:11 PM »
so is building under water necessary to trigger the crash?

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #12 on: December 16, 2009, 05:07:53 PM »
so is building under water necessary to trigger the crash?

Not at all. Happens with tunnels high up and any elevated monorails as well.

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: Constant crashing attempting underground/elevated construction
« Reply #13 on: December 16, 2009, 05:25:33 PM »
I could not reproduce it with my own build... (-> some pointer issue?)

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Constant crashing attempting underground/elevated construction
« Reply #14 on: December 16, 2009, 07:13:29 PM »
What would a save game tell? This happens with newly created games and everything so I'm not sure it would tell anything. It does happen more frequently with later highly developed games however. Most of the games I play regularly have so much custom paks so it would be useless to post them.

Well for a start, it means that the problem could possibly be reproduced if it is something that you are doing wrong, because we could actually play YOUR game. I for one am having no trouble with underground roads or rail.

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #15 on: December 16, 2009, 08:04:03 PM »
Well for a start, it means that the problem could possibly be reproduced if it is something that you are doing wrong, because we could actually play YOUR game. I for one am having no trouble with underground roads or rail.

http://simutrans-germany.com/files/upload/test76.sve

Doesn't seem to crash (yet) in the main city, but at various areas tried in the woods across the map, it crashes for me.

Furthermore it seems many people are unable to reproduce it since I haven't really seen it reported already anyway.

Offline z9999+

  • Coder/patcher
  • *
  • Posts: 377
Re: Constant crashing attempting underground/elevated construction
« Reply #16 on: December 16, 2009, 08:36:14 PM »
Tested in r2944 with Junna 's savegame.
While building elevated monorail with dragging, it sometimes caused to crash.

Quote
sim.exe caused an Access Violation at location 0057ebae in module sim.exe Reading from location 0ca17000.

Registers:
eax=0ca17000 ebx=0ca16ff8 ecx=00000004 edx=0bdd12fc esi=006921e8 edi=dd2c12cc
eip=0057ebae esp=0023c950 ebp=0023edd8 iopl=0         nv up ei pl nz ac po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000216

Call stack:
0057EBAE  sim.exe:0057EBAE  planquadrat_t::boden_entfernen(grund_t*)  simplan.cc:152
00576080  sim.exe:00576080  simu_main(int, char**)  simmain.cc:1010
005EA597  sim.exe:005EA597  WinMain  simsys_w16.cc:791
00401247  sim.exe:00401247
00401298  sim.exe:00401298
7C817077  kernel32.dll:7C817077  RegisterWaitForInputIdle

Quote
Message: two_click_werkzeug_t::move:   Button: 1, Pos: 350,209,1
Message: wegbauer_t::route_fuer():   setting way type to 517, besch=Suspended_Monorail_Track, bruecke_besch=NULL, tunnel_besch=NULL
Message: wkz_wegebau():   builder found route with 8 sqaures length.
Message: wegbauer_t::calc_costs():   construction estimate: 16800.000000
Message: two_click_werkzeug_t::move:   Button: 1, Pos: 351,211,1
Message: wegbauer_t::route_fuer():   setting way type to 517, besch=Suspended_Monorail_Track, bruecke_besch=NULL, tunnel_besch=NULL
Message: wkz_wegebau():   builder found route with 11 sqaures length.
Message: wegbauer_t::calc_costs():   construction estimate: 23100.000000
Message: two_click_werkzeug_t::move:   Button: 1, Pos: 354,215,0

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Constant crashing attempting underground/elevated construction
« Reply #17 on: December 16, 2009, 11:18:27 PM »
@Junna.

There you go, z9999+ found it straight away from your save game. He may not have fixed it, but he found it, saves a lot of guess work and questions floating around. The developers may now be able to correct the problem.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4587
  • Languages: EN, DE, AT
Re: Constant crashing attempting underground/elevated construction
« Reply #18 on: December 17, 2009, 08:19:41 AM »
Could you please retest with 2945? Found something, which may or may not have triggered the crash.

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #19 on: December 17, 2009, 05:44:10 PM »
Could you please retest with 2945? Found something, which may or may not have triggered the crash.

Where does one get 2945?

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3651
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Constant crashing attempting underground/elevated construction
« Reply #20 on: December 17, 2009, 05:47:08 PM »
http://simutrans-germany.com/~nightly/simutrans/

Basically, download an exe and at least one pak, extract to the same place (well, watch for directories - it used to be that pak128 would extract to "Simutrans", but everything else to "simutrans")

Also, looks like 2945 isn't out yet - check tomorrow. :)

Offline Junna

  • Devotee
  • *
  • Posts: 1080
Re: Constant crashing attempting underground/elevated construction
« Reply #21 on: December 18, 2009, 04:10:59 AM »
It appears the problem has indeed been rectified in 2947.  ;D

Offline Isaac.Eiland-Hall us

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3651
  • PanamaCityPC.com/support/
    • Facebook Profile
  • Languages: EN
Re: Constant crashing attempting underground/elevated construction
« Reply #22 on: December 18, 2009, 04:36:09 AM »
Huzzah! :D

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4587
  • Languages: EN, DE, AT
Re: [solved] Constant crashing attempting underground/elevated construction
« Reply #23 on: December 18, 2009, 06:05:26 AM »
:) thank you for the confirmation.

Offline z9999+

  • Coder/patcher
  • *
  • Posts: 377
Re: [solved] Constant crashing attempting underground/elevated construction
« Reply #24 on: December 20, 2009, 11:05:57 AM »
Not yet in branch.