The International Simutrans Forum

 

Author Topic: Mac OS X - Slowness  (Read 1962 times)

0 Members and 1 Guest are viewing this topic.

Nicolas Catalani

  • Guest
Mac OS X - Slowness
« on: July 17, 2010, 09:57:45 PM »
Hello everybody,
Today I installed on my Hackintosh (Mac OS X ported to PC) simutrans. I felt many delays, that the same computer with Windows 7 Ultimate did not happen and also a few days ago I had tested with the macbook of my friend and gave the same slowness.
What's wrong? In my opinion, I think the Slowness it's caused by the version being simply ported to Mac OS X.

Offline vilvoh

  • One of the good guys
  • Administrator (Inactive)
  • *
  • Posts: 4504
  • I'm the constructor, the architect
    • Escala real
Re: Mac OS X - Slowness
« Reply #1 on: July 17, 2010, 10:09:43 PM »
Please do a little search at the forum, the Mac slowness issue has been discussed several times before.

Nicolas Catalani

  • Guest
Re: Mac OS X - Slowness
« Reply #2 on: July 17, 2010, 11:08:06 PM »
Please do a little search at the forum, the Mac slowness issue has been discussed several times before.
Ok, thanks.

Offline micslu

  • *
  • Posts: 66
Re: Mac OS X - Slowness
« Reply #3 on: July 18, 2010, 10:33:35 AM »
Unfortunately the fundamental problem is that none of the Simutrans developers has Mac access so Mac specific bugs are left unresolved. It seems majority of Mac problems are related to SDL interaction.

I have MacBook and the arrow keys fail to move the map, making it very difficult to navigate. This seems to be a long unresolved problem. So I am resigned to playing Simutrans at work on Vista (crap!) PC behind several Excel worksheets but that's another story.

Cheers