The International Simutrans Forum

 

Author Topic: Canals not connecting to ocean?  (Read 2487 times)

0 Members and 1 Guest are viewing this topic.

Offline TygerFish

  • *
  • Posts: 107
Canals not connecting to ocean?
« on: December 04, 2010, 03:20:18 AM »
Just got latest: Experimental v8.2 & pak128.Britian-ex v0.6.

Ships can't find a route from ocean to canals. (See screenshots)

Offline inkelyad

  • Devotees (Inactive)
  • *
  • Posts: 482
  • Languages: EN, RU
Re: Canals not connecting to ocean?
« Reply #1 on: December 04, 2010, 05:19:53 AM »
How do you do that? Norfolk Wherry should be 'Waterway-only' (channels, rivers) in pak128.Britian-ex. It should not be able to go in sea.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18038
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Canals not connecting to ocean?
« Reply #2 on: December 04, 2010, 11:53:02 AM »
I think that Inkelyad has answered your questions - those boats are not suitable for use on the open ocean.

Offline TygerFish

  • *
  • Posts: 107
Re: Canals not connecting to ocean?
« Reply #3 on: December 04, 2010, 12:43:53 PM »
I think that Inkelyad has answered your questions - those boats are not suitable for use on the open ocean.
Unfortunately not...
Clyde screenshot: create one waypoint just before the transition and one just after.  Gets to first, balks at second.
Handysize screenshot: create only waypoints in the canal.  Will not leave depot.
Tested with other kinds of ships, with waypoints only before transition, only after transition, different kinds of transitions (including ocean->tunnel->ocean with no open canals) in different places... same thing happens in all cases: vehicles don't know how to travel from ocean to canal.

How do you do that? Norfolk Wherry should be 'Waterway-only' (channels, rivers) in pak128.Britian-ex. It should not be able to go in sea.
It seems to have no problem with it, as do all of the vehicles.  As an aside, what is the preferred method to create canal-only water vehicles?  If the depot can only be created in the ocean and the vehicles are not supposed to be able to travel in the ocean...

Offline inkelyad

  • Devotees (Inactive)
  • *
  • Posts: 482
  • Languages: EN, RU
Re: Canals not connecting to ocean?
« Reply #4 on: December 04, 2010, 01:44:42 PM »
same thing happens in all cases: vehicles don't know how to travel from ocean to canal.
That is right, ocean vehicles can't travel canals. (canals in pak128.Britain is shallow and narrow) And canal vehicles is not seaworthy.
Quote
If the depot can only be created in the ocean..
You are wrong. See screenshot.
« Last Edit: December 04, 2010, 01:57:13 PM by inkelyad »