The International Simutrans Forum

 

Author Topic: [Bug] v111.0  (Read 3071 times)

0 Members and 1 Guest are viewing this topic.

Offline transporter

  • *
  • Posts: 136
[Bug] v111.0
« on: January 02, 2012, 02:35:13 AM »
Found a crash for the game. No error box popped up and all the Terminal program said was world destroyed after the game load-up text. Gamer version 111.0 r4911M, pak128.britain v1.1 on Intel OSX. Steps: Load up the save and pause the game. Move the view to Southampton and delete the bus stop and terminal then rebuild the same models so they read as the airport stop. Build a garage on the end of road directly right (north) of the airfield stop by the soccer field. Make a bus route between the 2 stops then move to Hartlepool and build a garage next to the closest soccer field. Make a route between the bus stops and select the garage. Assign 4 or 6 Guy Specials (crashed with both) to that line. Go back to the Southampton garage and assign 3 Guy Specials to that line. Go to the Farnham airport and assign 1 BAC 111-500 for both routes 1 and 2. Then fast-forward and it should crash before the next year. I have no idea what combination or single event makes it crash. I tried to see if it was the save itself by fast-forwarding but got past the timeline for the crash so that wasn't it. It seemed to have crashed the whole program I think, because it caused the Apple Crash Report to open.


P.S. The load screen for pak.britain still reads v1.08


Savegame: https://docs.google.com/open?id=0B4x-6whHppW7OGFiMWYyZGYtYTRjMy00ZjcxLWExZTgtZDEzN2ZjOTA0ZWE0

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: [Bug] v111.0
« Reply #1 on: January 02, 2012, 09:42:12 AM »
Please try this again in a nightly as several cause for such crashes might have been removed in the meantime. You will find the nightlies here: http://nightly.simutrans-germany.com/

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #2 on: January 02, 2012, 05:51:32 PM »
Same crash, replicated exactly as above with r5070. With the length of time before crash, I'm pretty sure it has to do with the monthly bankruptcy report. I've tried with only aircraft and an account of -$1M in the hole and crashes before it reaches February

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4564
  • Languages: EN, DE, AT
Re: [Bug] v111.0
« Reply #3 on: January 02, 2012, 06:33:38 PM »
still could not reproduce it.

Can you upload the savegame right before the crash?

And can you start simutrans with "-log 1 -debug 3" and post the simu.log file after the crash?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: [Bug] v111.0
« Reply #4 on: January 02, 2012, 10:44:18 PM »
Maybe a wrong translation. What langugae did you set it too?

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #5 on: January 03, 2012, 02:51:37 AM »
It's in English. It's been that the whole time. Also, I opened up a completely new game to see if I get a bankruptcy report at all, ran up a debt of -$2M and no report at all.

Here's the savegame for the original scenario posted. Just let it run and the crash happens (for me) before 1:00h in February. https://docs.google.com/open?id=0B4x-6whHppW7NTcwODYwZTctNTU4Mi00ZmZlLTllYjQtOTZmOTk5NTQzNjcz

Remind me how to run the debug code. I did it once before, but forgot how

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: [Bug] v111.0
« Reply #6 on: January 03, 2012, 10:27:17 AM »
at the command line add "-debug 3 -log 1"

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4564
  • Languages: EN, DE, AT
Re: [Bug] v111.0
« Reply #7 on: January 03, 2012, 11:39:46 AM »
Could not reproduce it, also valgrind did not show any suspicious things :(

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #8 on: January 03, 2012, 04:42:52 PM »
Hmmm....I'll start another scenario with a similar setup using airports to connect the cities and see if it will crash again. It could just be a isolated event for that specific game. Do you at least get a bankruptcy report?

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #9 on: January 04, 2012, 05:17:12 PM »
I just tried with pak128 and the same thing happens. If I start a new map with airports and aircraft, the game crashes after a month of running. This time I had a positive account though

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: [Bug] v111.0
« Reply #10 on: January 04, 2012, 08:42:32 PM »
Looks like you translations are broken. Either reinstall the executable from sourceforge or download new tranlations from simuranslator.

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #11 on: January 04, 2012, 11:20:03 PM »
Downloaded translations for the executable and the paks, downloaded a new nightly, pakset, and the package from sourceforge and still get the same crash.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: [Bug] v111.0
« Reply #12 on: January 05, 2012, 08:23:13 AM »
Hello

Have you tried deleting the settings.xml file?

In windows the file is in documents\simutrans folder.

Giuseppe

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #13 on: January 05, 2012, 07:36:34 PM »
I found a settings.txt file in the simutrans\text\en, and I run a Mac. I also looked in the library folder and didn't find that file.

Offline Milko

  • Devotee
  • *
  • Posts: 828
Re: [Bug] v111.0
« Reply #14 on: January 07, 2012, 04:38:10 PM »
Hello

It is a file "xml", contains the configuration of simutrans. I do not know where he is in the mac ...

   Maybe someone who uses the mac can help.

Giuseppe

Offline transporter

  • *
  • Posts: 136
Re: [Bug] v111.0
« Reply #15 on: January 08, 2012, 05:52:12 AM »
There's a settings.xml in the Library folder, and the simuconf.tab in the main folder.