Simutrans Forum Archive
A complete record of the old Simutrans Forum.

TileCutter 0.6.1 Release

Started by Ashley, January 29, 2012, 01:23:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


If you do encounter any issues while using TileCutter please submit a bug report by posting in reply to this thread with the following information:

1. Circumstances and description of the issue
2. tilecutter.log and TileCutter5.exe.log (if present) - These can be found under "%USERPROFILE%\Application Data\tilecutter\" on Windows, "~/Library/Logs/tilecutter.log" on OSX and "~/.tilecutter/tilecutter.log" on all other platforms.
3. Copy of the tilecutter.config file - This can be found either in the program's installation directory, at "%USERPROFILE%\Application Data\tilecutter\" on Windows or "~/.tilecutter/tilecutter.config" on all other platforms.

Release 0.6.1
FIX: Infinite loop in dialog

Release 0.6.0
FIX: Source version works again, remove FileControl from tcui
FIX: Irregular buildings work again
ADD: Remember last folder location for open/save files
FIX: Z dimensions now permitted up to 16 (from previous max of 4)
ADD: Browse dialog for makeobj path selection
FIX: Cutting masks incorrectly generated on OSX platform


Please see here for TileCutter documentation

All the paths in the main window are relative to the project save location path. This is intended to allow you to put all your work files in one directory, and then to be able to move or zip that directory and send it to someone else while preserving all the links to the images. Also note that the images are not saved with the project file, only links to them are (this may change at some point).

It's also worth pointing out that in order for the one click exporting to work (e.g. makeobj integration) you need to have filled out the correct details in the dat editing window. The image array information is automatically generated and appended to whatever you type into this box.

You can download this release of TileCutter from the following link for the Mac:

TileCutter_osx_0.6.1.dmg (15 MB)

And for windows: (5.4 MB)

You can also download a source distribution (all other platforms): (232 KB)

NOTE: The source distribution requires that you have Python 2.7 or better installed already, and depends upon the wxWidgets library (2.8.12 Unicode version recommended). It may work with other versions, but this is untested.

The latest source code can be obtained via Git:

I recommend upgrading to this version over all previous versions of TileCutter, especially the 0.3 branch.
Use Firefox? Interested in IPv6? Try SixOrNot the IPv6 status indicator for Firefox.
Why not try playing Simutrans online? See the Game Servers board for details.


I can't use a big image. I tried a 512x512 and it don't load. Nothing shows in the window.
I'm running in Win7 x64.

I've attached my log.

By instance, I want to use estadio projeto 9 image from this topic

I found that the image is that don't open, I've got one that open and just pasted it in and now it works. Couldn't spot any differences between the files.

The Transporter

Thanks for the Update! Now it works fine!


I recently started using tile cutter. I mean... this is one big life saver. Saves so much time. Thank you so much for having made this program.


Use Firefox? Interested in IPv6? Try SixOrNot the IPv6 status indicator for Firefox.
Why not try playing Simutrans online? See the Game Servers board for details.

The Transporter

The 0.6.1 release is a great step ahead. Thanks for this really nice tool.  :D

The Transporter

A idea for the next release.
Please make the output Path savable. My working directory is not in the user path. I have to select after starting tilecutter the path


I think that TileCutter would deserve following:

1. all eight views - even if this option has been used only for buildings of types com, ind and res - and if only few people use this option
2. views for animated buildings (this may be a little more useful than previous)
3. dat file options in style of old tilecutter - at least for some options

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní


Before the movie Gone with the Wind was made, the part of Scarlett was offered to Bette Davis.  She was angry with the studio at the time for only giving her what she considered crappy roles and quipped "I bet it's a pip."

For awhile I kept seeing posts saying "download TileCutter."  For some reason I was in Bette Davis mode thinking I didn't need it.  Was I ever wrong!  It is really great Timothy!  Thank you very much for providing us with this wonderful tool.

The Hood

I'm having a problem with the latest release 0.6.1 on windows 7. When I execute the program, the icon appears in the task bar on the bottom and appears on the alt+tab window, but I can't actually view the tilecutter window. Any ideas? I can't seem to find an up to date tilecutter.log either.


I don't know. I can only ask you: Have you installed all you need?

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní



Link should be fixed now, sorry I didn't notice this earlier!
Use Firefox? Interested in IPv6? Try SixOrNot the IPv6 status indicator for Firefox.
Why not try playing Simutrans online? See the Game Servers board for details.


today I found something very strange in TileCutter.

It has a problem with Z dimension.
I have building with 4 rotations, length/width 5*1 - and with height 2. But this height is only in centre of building - and height 1 is exceeded of only few pixels - only in two of four rotations.

TileCutter cuts building only in height 1, even if I set height 2 - and so small part of building is missing.

For test of this bothering bug I attached all source files (4 original + cursor and icon - and also cut and dat). I am sorry for czech language, so: sever - north, jih - south, východ - east, západ - west.

Edit: partly solved - only original problem (above) stays

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní


What are you talking about? I can see them on [0,6] and [6,0]

The only thing is that TileCutter could check all empty tiles and merge them in one, this would reduce size.


I see that part on 0,5 (not 0,6) - but it seems like all was solved.

At least in that way I made central part a little higher (one floor) that now it is exceeding into height 2 in all four rotations. It is reason that I will not add on that station something what I wanted, but now it is a little better.

And about free tiles:

I think that sheet from version 0.3.1, where all tiles were in form that shape of building was well visible - even if those sheets contained much free tiles, but it could be solved by change of order of rotations in sheet.

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní


But still ..., TileCutter would deserve correction of choosing of rotations when all images are in one - because in some widths (if widths are not in multiplies of basic size of pakset) it is problem to target some rotations right.

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní

The Transporter

My Tilecutter is not running correct. Only the Icon is in the Taskbar.
2 Weeks ago all was Ok. I have nothing installed since the last positive Start of Tilecutter. New installation did not help.


Try erasing the user config of TileCutter, on Windows it's in /Users/Username/AppData/Roaming/tilecutter/

It probably won't help :) but it doesn't hurt to try.

The Transporter

Thanks for this Tip!
Now it's working again. ;D ;D ;D ;D