The International Simutrans Forum

 

Author Topic: Jenny Lind/LNWR Crewe Type 90km/h, track not matching  (Read 1449 times)

0 Members and 1 Guest are viewing this topic.

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Jenny Lind/LNWR Crewe Type 90km/h, track not matching
« on: April 29, 2012, 08:43:25 PM »
Just to report a couple of probably unrelated issues encountered at the same time.

Firstly, my game is in 1848, I have the LBSCR Jenny Lind and LWNR Crewe Type locomotives available, with top speeds respectively 95km/h and 90km/h. However, the only track available is "Wrought Iron Track" 60km/h, which doesn't seem quite right.

Secondly, I have Jenny Linds pulling rakes of 10 100km/h LWNR coaches, which should obtain a Max Speed of 70km/h according to the Depot dialogue. However, the train refuses to accelerate past 50km/h. Occurs to me that possibly the 60 km/h track is in fact coded at 50km/h?

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18492
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Jenny Lind/LNWR Crewe Type 90km/h, track not matching
« Reply #1 on: April 29, 2012, 09:03:19 PM »
The track speed issue has been fixed on the Github branch and will be 110km/h in the next version.

On my -devel branch, I get the correct result: it gives a maximum speed of 87km/h, and in fact reaches 86km/h (a rounding error, I suspect).

Thank you for the reports, however!

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Re: Jenny Lind/LNWR Crewe Type 90km/h, track not matching
« Reply #2 on: April 30, 2012, 06:37:47 PM »
No trouble, am glad it was an easy one!