The International Simutrans Forum

 

Author Topic: Art deco style Underground station  (Read 3622 times)

0 Members and 1 Guest are viewing this topic.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Art deco style Underground station
« on: May 07, 2012, 11:42:28 PM »
Following the previous Yerkes style station, now something from the 1930s: an art deco style underground station modelled loosely on Turnpike Lane, opened in 1932. Sample image attached, .dat file available here.

Image files as below:





Translation text:

Code: [Select]
art-deco-underground-station-building
Tube station building

Offline kierongreen

  • Dev Team, Coder/patcher
  • Moderator
  • *
  • Posts: 2269
Re: Art deco style Underground station
« Reply #1 on: May 08, 2012, 06:28:27 AM »
You have rotated light sources along with model... :p roof looks a bit... plain? other than that looking good :)

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #2 on: May 08, 2012, 01:42:33 PM »
Ahh, I must confess, I am not exactly sure precisely how it works with lighting. I know that Zeno's automatic renderer, as adapted by The Hood, does indeed rotate the lighting dome; I also know that, on existing buildings (such as depots) the light appears differently shaded from different angles. May I ask - what exactly should and should not be rotated?

As for the roof, were they not very plain in real life in this period?

Offline The Hood

  • Moderator
  • *
  • Posts: 2889
  • pak128.Britain developer
Re: Art deco style Underground station
« Reply #3 on: May 08, 2012, 02:17:14 PM »
In my auto-render script, the light and camera moves and the object does not. It would appear that in whatever version you are using (didn't you adapt it somehow?) the camera moves, and the object and lights do not (or vice versa).  As long as the lights are always fixed relative to the camera, it should give the correct results.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #4 on: May 08, 2012, 03:32:12 PM »
Ahh, I see - now all becomes clear - thank you! I had trouble using the automatic render script with these, as they would not rotate evenly around the centre - I had to rotate them manually. I rotated the object and the lighting dome, which would explain the results. I shall have to try again rotating only the object.

Incidentally, is the large black transparent/outlined object on layer 2 the camera or an extra light?

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #5 on: May 14, 2012, 12:20:49 AM »
I have now fixed the lighting on this.

Offline kierongreen

  • Dev Team, Coder/patcher
  • Moderator
  • *
  • Posts: 2269
Re: Art deco style Underground station
« Reply #6 on: May 14, 2012, 05:45:18 PM »
Great :) Now some suggestions regarding textures:
Pavement - use the standard texture
Roof - for the summer version make it slightly darker overall but with the same pattern ou are currently using on the winter version to give it some interest. For the winter version lighten it more so that it more obviously appears as snow.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #7 on: May 14, 2012, 10:05:43 PM »
Hmm - I thought that I had used the standard texture? And what HSV (or, rather, V) setting should the snow be - I thought that I set it to the standard 0.8?

Offline kierongreen

  • Dev Team, Coder/patcher
  • Moderator
  • *
  • Posts: 2269
Re: Art deco style Underground station
« Reply #8 on: May 14, 2012, 10:24:19 PM »
Standard pavement texture:
http://simutrans.svn.sourceforge.net/viewvc/simutrans/pak128.Britain/citybuildings/images/pavement.png

For example of how white snow should appear:
http://simutrans.svn.sourceforge.net/viewvc/simutrans/pak128.Britain/stations/large-terminal-1950s.png


I'm not sure of exact hsv values that should be used to achieve this

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #9 on: May 14, 2012, 10:26:59 PM »
Hmm - the odd thing is that I took the texture from the standard textures folder. Was there something else that had to be done?

Offline kierongreen

  • Dev Team, Coder/patcher
  • Moderator
  • *
  • Posts: 2269
Re: Art deco style Underground station
« Reply #10 on: May 14, 2012, 11:14:28 PM »
It may need a colour for the surface it is on too - if you copy the pavement surface across from the pavement blend file (or any building with a pavement) then it should display correctly (hopefully!)

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Devotee
  • *
  • Posts: 18425
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Art deco style Underground station
« Reply #11 on: May 19, 2012, 12:02:46 PM »
I have now fixed the paving colour - see the image above.

Offline kierongreen

  • Dev Team, Coder/patcher
  • Moderator
  • *
  • Posts: 2269
Re: Art deco style Underground station
« Reply #12 on: May 19, 2012, 12:17:37 PM »
Getting there :) Summer images could do with some kind of subtle texturing on roof (even a slab of concrete is not usually just one colour, especially after a few years). In the winter images the snow is not quite clear enough on roof (look at difference in light between summer and winter pavements relative to that on this building roof).