The International Simutrans Forum

 

Author Topic: 111.2.2 doesn't remember "beginner mode"  (Read 2844 times)

0 Members and 1 Guest are viewing this topic.

Offline Fraoch

  • *
  • Posts: 81
  • Languages: EN, FR
111.2.2 doesn't remember "beginner mode"
« on: May 18, 2012, 07:40:19 PM »
Hello:

If I start a game in 111.2.2 with "beginner mode" selected everything runs as expected.

However if I restart, suddenly the game is no longer in beginner mode.

It looks like this setting isn't being retained.  Is this a bug?

System: AMD Phenom II X3 B73, 4 GB RAM, Ubuntu 12.04 32-bit.

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #1 on: May 18, 2012, 08:16:59 PM »
Same for timelime, although it will be loaded from saved games new map settings don't seem to be retained, investigating

Offline Fraoch

  • *
  • Posts: 81
  • Languages: EN, FR
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #2 on: May 18, 2012, 08:18:32 PM »
Actually it seems that "beginner mode" isn't used at all regardless of the setting and regardless of rebooting.

Unless the rules have changed?  It used to be that in beginner mode you could send cargo to a destination even after it's fully stocked.  Now once the destination is fully stocked the producers stop sending it cargo, even in beginner mode.  Is this correct?

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #3 on: May 18, 2012, 08:50:11 PM »
You should be able to send cargo regardless (just in time disabled). Confirmed beginner mode (at least in this aspect is being ignored).

Offline Fraoch

  • *
  • Posts: 81
  • Languages: EN, FR
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #4 on: May 18, 2012, 08:52:23 PM »
OK thanks!  It's not just me then.

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #5 on: May 18, 2012, 11:59:12 PM »
Right, two issues at play here!

First the saving of the setting - simutrans does save this correctly, however the simuconf.tab files used in the debian package overwrite this. Load the simuconf.tab file for simutrans and your pakset (e.g. /usr/share/games/simutrans/config/simuconf.tab and /usr/share/games/simutrans/pak128.Britain/config/simuconf.tab) and change the following line:
first_beginner = 0
to
#first_beginner = 0

As for simutrans not applying just-in-time when using beginner mode I think this is a bug in simutrans, I've written a patch which seems to fix this (http://forum.simutrans.com/index.php?topic=9948) however you may have to wait a while for this to filter through to debian. In the meantime if you change the following line in your simuconf files (locations as above):
just_in_time = 1
to
just_in_time = 0
this should disable just-in-time in the game

Another note:
Editing these simuconf files may require root privileges - an alternative could be to copy this file into /home/<username>/.simutrans and edit it there - this should take priority over the system version. One problem with this however is that the system files have already set first_beginner = 0 so you cannot unset this and get simutrans to save the beginner setting used on the new world menu (you can set first_beginner = 1 to force the setting on startup though).

Offline DirrrtyDirk

  • Devotees (Inactive)
  • *
  • Posts: 1253
  • JR 700 Series Shinkansen
  • Languages: EN,DE
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #6 on: May 19, 2012, 10:17:20 AM »
As for simutrans not applying just-in-time when using beginner mode I think this is a bug in simutrans,

I'm not sure... but I think I remember reading that this was actually intended...

Offline kierongreen

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 2269
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #7 on: May 19, 2012, 11:07:53 AM »
Given that the code at least tries to disable just in time for beginner mode currently I'm inclined to think that is the intended behaviour.

Offline Fraoch

  • *
  • Posts: 81
  • Languages: EN, FR
Re: 111.2.2 doesn't remember "beginner mode"
« Reply #8 on: May 19, 2012, 03:46:41 PM »
Right, two issues at play here!

First the saving of the setting - simutrans does save this correctly, however the simuconf.tab files used in the debian package overwrite this. Load the simuconf.tab file for simutrans and your pakset (e.g. /usr/share/games/simutrans/config/simuconf.tab and /usr/share/games/simutrans/pak128.Britain/config/simuconf.tab) and change the following line:
first_beginner = 0
to
#first_beginner = 0

As for simutrans not applying just-in-time when using beginner mode I think this is a bug in simutrans, I've written a patch which seems to fix this (http://forum.simutrans.com/index.php?topic=9948) however you may have to wait a while for this to filter through to debian. In the meantime if you change the following line in your simuconf files (locations as above):
just_in_time = 1
to
just_in_time = 0
this should disable just-in-time in the game

Another note:
Editing these simuconf files may require root privileges - an alternative could be to copy this file into /home/<username>/.simutrans and edit it there - this should take priority over the system version. One problem with this however is that the system files have already set first_beginner = 0 so you cannot unset this and get simutrans to save the beginner setting used on the new world menu (you can set first_beginner = 1 to force the setting on startup though).

Thanks for this detailed workaround.  I haven't tried it out yet but thank you!

As for whether it's intended behaviour or not, I hope not...I've tried just-in-time a few times and I can never seem to make any money at it.  :-(