Author Topic: [pakHD] Iron Industry Bug  (Read 3776 times)

0 Members and 1 Guest are viewing this topic.

Offline WTell

[pakHD] Iron Industry Bug
« on: August 26, 2011, 04:29:15 PM »
I recently had a game where everythnig was giong perfectly, until I realized that my iron industry was only linked to iron ore, and that no coal could be provided to the factory. This caused my iron factory to produce nothing as it didn't have the appropriate materials.  I could have gone in an added the factory manually via PS, but I usually consider that cheating !

What I think happened was that the coordinates of the coal mine which was supposed to be linked up to the factory were somehow changed or the coal mine itself was deleted after it was connected.  I think this because, of the three 'links' the iron factory had, two were to iron mines as was proper and the last was an 'empty' link.  It linked me to the middle of nowhere.  This was frustrating.

Also, just FYI:
     * I am using the latest windows release via the on-line download installer as of August 25, 2011
     * I am using the HD pakset (which I don't think plays into the core mechanics here)
    * I am also using the default setting.  The only values I changed in map gen were map size, city number, factory number, and attraction number.

UPDATE:  Looking into the problem a bit more, I found that it held true with all industries, and affected industry connections as well as connections with cities (workers live in XX).  What happens is that on the factory information pop-up empty links sometimes show up which take you nowhere.  BUT looking through the factory list, I noticed these 'blank' links were actually representative of a link in another factory to the factory in question. 

For example, a cement mill was connected to a stone quarry as well as an 'empty' link.  Instead of linking it up to a coal mine right away, I looked through the existing coal mines and found one which was linked to the mill.  Assigning it to a line, I found that goods moved normally between the two EVEN THOUGH THE COAL MINE DID NOT APPEAR ON THE CEMENT MILL's CONNECTED FACTORY LIST.  This is, I think, a bug.

Also, on this same factory there was a list of nearby cities.  One did not have a 'zoom to' link next to it, and one was left blank.  What had happened was that the link column had shifted down one line, so the links and the named cities did not line up.  While this might be a problem with my individual system, I think the problem is probably within the game itself.  Has anyone noticed these specific problems happening before?

« Last Edit: February 07, 2012, 08:43:20 PM by Dwachs »

Offline Václav

  • Devotee
  • *
  • Posts: 3229
  • Total likes: 14
  • Helpful: 16
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Iron Industry Bug
« Reply #1 on: August 26, 2011, 05:55:30 PM »
My help is based on pak1128 but it should be the same also for pak96.HD

Factories like steel mill or so have not set number of suppliers. There is only set that it needs iron ore and coal, anything else. But it can happen that any factory may appear without all suppliers: mostly it happens with final members like Supermarket or Shapping mall - but sometimes it can happen to factories like steel mill.

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní

Offline WTell

Re: Iron Industry Bug
« Reply #2 on: August 26, 2011, 06:05:58 PM »
My help is based on pak1128 but it should be the same also for pak96.HD

Factories like steel mill or so have not set number of suppliers. There is only set that it needs iron ore and coal, anything else. But it can happen that any factory may appear without all suppliers: mostly it happens with final members like Supermarket or Shapping mall - but sometimes it can happen to factories like steel mill.

So does that mean that some industry chains are built to fail?? When this happens is it best to just ignore the industry?

Offline Václav

  • Devotee
  • *
  • Posts: 3229
  • Total likes: 14
  • Helpful: 16
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Iron Industry Bug
« Reply #3 on: August 26, 2011, 06:45:05 PM »
Yes - but very rarely (but ... there is one more way why it happens - if that chain is quite new, factories may be coded wrong - and for example there may be wrong year of appearing in game or wrong year when it becomes obsolete - but I have not source for that pakset)
Yes - or you can switch to public services and manually add missing supplier (and connect it with next member of chain)

Chybami se člověk učí - ale někteří lidé jsou nepoučitelní

Offline WTell

Re: Iron Industry Bug
« Reply #4 on: August 26, 2011, 10:08:28 PM »
I looked into the problem a bit more and posted an update. 

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4279
  • Total likes: 195
  • Helpful: 149
  • Languages: EN, DE, AT
Re: Iron Industry Bug
« Reply #5 on: August 31, 2011, 04:48:52 PM »
@WTell: can you upload your savegame at http://files.simutrans-germany.com/ ?
Parsley, sage, rosemary, and maggikraut.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8830
  • Total likes: 324
  • Helpful: 229
  • Languages: De,EN,JP
Re: Iron Industry Bug
« Reply #6 on: August 31, 2011, 08:17:50 PM »
This is a problem in pakHD: The coal mine is only 2x2 but is defined as 3x3 in the pak. As soon as the map is rotated, it will loose its connections in two rotations.

There are other problems in pakHD as well: Pressing e will terminate simutrans.

The menuconf.tab of pakHD was completely messed up:
THERE MUST BE NOT TEXT AT ALL AFTER A COMMAND!!!

Please replace it with the attached one:
« Last Edit: August 31, 2011, 08:35:21 PM by prissi »

Offline WTell

Re: Iron Industry Bug
« Reply #7 on: September 01, 2011, 02:11:00 AM »
Unfortunately I don't have the save anymore.  I should have kept it, but I haven't used PackHD since the bugs.  you should be able to reproduce it... it seems to happen a lot with oil rigs.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8830
  • Total likes: 324
  • Helpful: 229
  • Languages: De,EN,JP
Re: Iron Industry Bug
« Reply #8 on: September 01, 2011, 12:27:55 PM »
The problem is a wrong dat file definition: THe size of the coal mine must be 2x2 instead 3x3 as in the file.