Author Topic: Please Help - Custom Maps Not Working  (Read 183 times)

0 Members and 1 Guest are viewing this topic.

Offline The13thRonin

Please Help - Custom Maps Not Working
« on: January 10, 2018, 08:50:12 AM »
Hi all,

I have a problem with most maps I download from http://maps.simutrans.com not working. For example this map:

http://maps.simutrans.com/northamerica.html

Is half underwater and the rest of the terrain is desert even when I set water level to -10.

Is there a way to fix this? I would like to play with custom maps.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8863
  • Total likes: 336
  • Helpful: 230
  • Languages: De,EN,JP
Re: Please Help - Custom Maps Not Working
« Reply #1 on: January 10, 2018, 11:29:24 PM »
You have to set the climate borders to some sensible values. If you set the water level to -1 and the next climate is desert after that mediterrian at 0, then all levels between-10 and 0 are desert.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4971
  • Total likes: 229
  • Helpful: 111
  • Languages: EN, NO
Re: Please Help - Custom Maps Not Working
« Reply #2 on: January 11, 2018, 06:41:05 AM »
You have to set the climate borders to some sensible values. If you set the water level to -1 and the next climate is desert after that mediterrian at 0, then all levels between-10 and 0 are desert.
(Emphasis mine.)

I suppose you mean -10 and not -1.

Offline Leartin

Re: Please Help - Custom Maps Not Working
« Reply #3 on: January 11, 2018, 07:44:53 AM »
Note that in the "Landscape Settings", climates can't start lower than -5, while going to the Landscape tab in the general settings allows to go down as far as the water level was when the window was opened. To achieve a setting of desert below -5, you'd have to open the Settings, change to the Landscape tab, set the water level to -10, close the settings window, open it again, switch to landscape tab again and then you should be able to set desert at -9.