The International Simutrans Forum

Development => Patches & Projects => Incorporated Patches and Solved Bug Reports => Topic started by: 1993matias on October 27, 2013, 11:22:23 AM

Title: [192c] Crashes when electrifying track (solved)
Post by: 1993matias on October 27, 2013, 11:22:23 AM
Hi there,


I've encountered a problem: I try to electrify a recently built stretch, but the game crashes.
I select the electrification tool and follow the path as indicted by the arrow. The electrification should now follow the dotted line, but the game just crashes. I've tried to electrify one track at a time, but nothing happens then...
(http://i330.photobucket.com/albums/l405/skoleboss/random%20things/Unavngivet_zps1e4b325a.png~original)


Savegame (https://drive.google.com/file/d/0BxL13clucqWlb0o3bG1mcUJoUWc/edit?usp=sharing)


Simutrans version 112-3 r6520
Pak version 192c v0.3, no add-ons
Title: Re: [192c] Crashes when electrifying track
Post by: Václav on October 27, 2013, 11:49:14 AM
Isn't better to download newest (nightly) version from http://nightly.simutrans-germany.com/ ?
Title: Re: [192c] Crashes when electrifying track
Post by: Ters on October 27, 2013, 12:54:26 PM
This sounds like a known error that has been fixed. Nightlies can however potentially have even worse problems. While I don't remember having serious problems (only settings reverting to default once), I advice backing up savegames before loading (or rather saving) them in a new nightly version.
Title: Re: [192c] Crashes when electrifying track
Post by: 1993matias on October 27, 2013, 01:03:31 PM
Thanks, so it will be fixed in the next release of Simutrans?
Title: Re: [192c] Crashes when electrifying track
Post by: Ters on October 27, 2013, 01:37:27 PM
Thanks, so it will be fixed in the next release of Simutrans?

Yes, but I fear it may take some time before a new official release is made. Maybe not this year, although much can change in a month. Not that I'm any authority on this.
Title: Re: [192c] Crashes when electrifying track
Post by: 1993matias on October 27, 2013, 02:21:40 PM
Thanks for the help :)
But now I can't make the nightly work... I get this error:
Quote
FATAL ERROR: alles_geladen() - 12skin_besch_t-object Squarebutton not found.
Any idea on where to post it? Just a new thread here? Thanks :)
Title: Re: [192c] Crashes when electrifying track
Post by: Ters on October 27, 2013, 02:38:36 PM
I think you're having troubles with this: http://forum.simutrans.com/index.php?topic=12556.0
Title: Re: [192c] Crashes when electrifying track
Post by: 1993matias on October 27, 2013, 03:03:57 PM
Thanks, it worked :D