The International Simutrans Forum

PakSets and Customization => Pak64 => Pak64 Bug Reports => Topic started by: wernieman on November 13, 2013, 07:25:55 AM

Title: [solved] Problem with generation PAK64 on nightly-Server
Post by: wernieman on November 13, 2013, 07:25:55 AM
Hello,

I have a Problem with generation PAK64 in the nightl-Server (Linux 64Bit-System)
I make a new lightmap (r1313) and try in PAK64 (r1312)
Code: [Select]
simutrans@hedwig ~/PAK/pak64 $ make
===> COPY
find: warning: you have specified the -depth option after a non-option argument (, but options are not positional (-depth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

===> Grounds calculations
===> OUTSIDE with REVISION and grounds
Makeobj version 55.2 for Simutrans 112.4 Nightly and higher
libpng warning: Interlace handling should be turned on when using png_read_image
libpng warning: Interlace handling should be turned on when using png_read_image
libpng warning: Invalid pHYs after IDAT
===> PAK64 city_extra
Makeobj version 55.2 for Simutrans 112.4 Nightly and higher
make: *** [city_extra] Fehler 3
could somebody help?

Edit:
The Version before (r1311) work. So the error is between 1311 and 1312

Greeting,
Werner
Title: Re: Problem with generation PAK64 on nightly-Server
Post by: wernieman on November 13, 2013, 07:45:48 AM
Sorry for the Bug-Report ... I need a "new" makeobj ....

I build it and it  .... works

Edit BTW:
there is in the Makefile a Line:
@find $(PAKDIR)/scenario "(" -name ".svn" ")" -depth -exec rm -rf {} \;

But ... it would be better to wrote:
@find $(PAKDIR)/scenario -depth "(" -name ".svn" ")" -exec rm -rf {} \;

It is better to use the depth Parameter before the other Parameter ....
Title: Re: [solved] Problem with generation PAK64 on nightly-Server
Post by: Ters on November 13, 2013, 03:57:58 PM
BTW to the BTW, something related to that find-stuff also broke parallel building for pak64.