The International Simutrans Forum

PakSets and Customization => Pak128 => Topic started by: Silver on February 14, 2009, 10:52:43 PM

Title: error in updating the pak 128 Version 1.4.4
Post by: Silver on February 14, 2009, 10:52:43 PM
I just downloaded version 1.4.4 and now I have a problem because I can not enter the game in the pak 128, because exist duplicate files if I have not installed anything more than once, all deposits, airports, bus stop, post office and all terminal.

There are addons in pak 128-1.4.4. I already had but with different names, this is not very good because the fact of taking an addon that had already been created and rename it, for my part they made a hair taken from for the creator of the addon and the player in this case because now I can not open the game as they are numerous addons duplicates, when a normally addon existing with the same name Windows tells you if you want to replace it again without the fear of duplication.

I hope this is taken into account and review all the duplicates if addons Japanese, English and others

_(http://forum.simutrans.com/index.php?action=dlattach;topic=1507.0;attach=4901;image)
______________________________________ _______________________________________

In the image appears the list of addons that I have removed it, but apparently has no end, because most are duplicates of the airport terminals, warehouses, train depots and terminals, some terminals and deposits of cars, parking, post offices, etc.. I will not put all because takes me too long, so I will choose to delete the pak 128 and to leave files compatibility, sound, setting, etc.., the good thing is that I have a backup of my pak but frankly this not okay, something someone wrong and would be good to place an notice or report of this.

_______________________________________ ______________________________________

Important: I take check the pak and I realize that several of the addons out as duplicates are loaded in the previous 128 pak for 1.4.3. - V-0100-A notice should explain where the updating and changing names of several addons, it is very important for players who like me are not know of what is done in the absence of a good translation of the updating of pak128 in spanish

sorry, me english is not good.

(http://forum.simutrans.com/index.php?action=dlattach;topic=1507.0;attach=4907;image)
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Frank on February 14, 2009, 11:05:45 PM
if exists file airports.all.pak?

not update 1.4.3.1pre to 1.4.4

version 1.4.4 new folder install
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Silver on February 15, 2009, 01:54:55 AM
airports.all.pak yes, the file exists and causes many problems of duplicate files with stations, terminals, warehouses, etc..

1.4.4 not good for the version 1.4.3pre
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: VS on February 15, 2009, 10:52:54 AM
1.4.3pre ≠ 1.4.3 ? If yes, 1.4.3pre - not official, not my problem ;D

You can fix:
1) Delete all paks, copy oficial set, copy addons (tiresome).
or
2) Use makeobj - unpack 1.4.4 to many small files, then copy over 1.4.3pre & replace files.
or
3) Make program, which deletes single pak files from official set (I can give list of all objects).
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Frank on February 15, 2009, 03:53:46 PM
1.4.3pre ≠ 1.4.3 ? If yes, 1.4.3pre - not official, not my problem ;D

...

1.4.3.1pre and not 1.4.3pre
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: VS on February 15, 2009, 04:38:46 PM
Version from August?
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Frank on February 15, 2009, 04:45:41 PM
Version from August?

yes

Version 1.4.3 for Simutrans 0.99.17.1
Version 1.4.3.1pre for Simutrans 0.100.0
Version 1.4.4 for Simutrans 0.101

Version 1.4.3pre not existent
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Silver on February 15, 2009, 04:54:29 PM
(I can give list of all objects).

if you please!

sorry :P, the vesion is 1.4.3.1pre
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: VS on February 15, 2009, 05:06:07 PM
Here. Format is:
object_type;name;author
so you can transform it to object_type.name.pak and have file names.
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Silver on February 15, 2009, 05:17:39 PM
o.k. thank's
Title: Re: error in updating the pak 128 Version 1.4.4
Post by: Silver on February 15, 2009, 08:41:40 PM
This done, I can play with the new version 1.4.4 and the addons I had before, here is a list of addons that I caused the problem and I had to delete for delete the duplicated:

asphalt_road: contains 1 file .pak = (way.asphalt_road)
A380-v2: contains 1 file .pak = (vehicle_A380)
DF4-128: (2) contains 2 files .pak = (vehicle_DF OC and PC)
DD51-128: (2) contains 8 files .pak = (vehicle_JNR and jrh)
128_road: contains 1 file .pak = (way.road)


All together, a total of 13 files with extension. pak, more the list of the image occasioning the conflict, I hope this list will serve as something to prevent future errors of duplicate.

Thank a lot everyone
Title: Vehicles doubled
Post by: ronnie89b on March 20, 2009, 06:52:58 PM
All vehicles doubled in the depot
r2391, pak128 v535
Title: Re: Vehicles doubled
Post by: Frank on March 20, 2009, 07:01:46 PM
this is a set problem

see http://forum.simutrans.com/index.php?topic=1510.0 (http://forum.simutrans.com/index.php?topic=1510.0)

modnote (whoami): topics merged
Title: Re: Vehicles doubled
Post by: ronnie89b on March 20, 2009, 07:55:10 PM
I deleted the game, then I "reinstall" it with the same addons and the problem solved