The International Simutrans Forum

Development => Bug Reports => Topic started by: Fietin on January 24, 2016, 05:45:23 PM

Title: disconnects with server game
Post by: Fietin on January 24, 2016, 05:45:23 PM
Good evening.
I have problems with the connection to the server game of the pak192.comic development-team since friday.
Every time, my client connected with the server the game are not synchron anymore after a few seconds.

I'm using r7640, which I have compiled for my xubuntu system.
Recompiling my client and rebooting the server didn't work.
After uploading my local autosave I was able to play without any issues yesterday. However, today I have the same problem again.
Uploading the autosave every day should not be the solution.

Other players are able to play without problems.

Do anyone of you know why I have this problem and how to solve it?

Fietin

(I'm sorry for my English skills. I'm not good in learning languages)
Title: Re: disconnects with server game
Post by: TurfIt on January 24, 2016, 06:13:11 PM
You need to determine the reason for the desync: http://forum.simutrans.com/index.php?topic=15109.0 (http://forum.simutrans.com/index.php?topic=15109.0)

Ensure you're using the exact same revision as the server. I don't see any pak192.comic servers on the serverlist -if you're connected manually to an unlisted server, the version checking is bypassed.

Possibly the same issue as we're discussing here: http://forum.simutrans.com/index.php?topic=15139.25 (http://forum.simutrans.com/index.php?topic=15139.25)
So far only apparent resolution is to build everything debug with 7731 or greater and using nothing newer than gcc 4.6.
Title: Re: disconnects with server game
Post by: Fietin on January 30, 2016, 10:25:58 AM
Thank you for your answer.
I answered not until now because I had no time the last five days.

The reason for desync was due to a program bug.
We are using r7720 instead of r7640 now and it's working since yesterday.

(I've installed gcc 5.2.1)
Title: Re: disconnects with server game
Post by: vzrenggamani on January 30, 2016, 10:32:40 AM
Ensure you're using the exact same revision as the server. I don't see any pak192.comic servers on the serverlist -if you're connected manually to an unlisted server, the version checking is bypassed.

Maybe he dont using -announce Command line..

I think pak192.comic have some problem for online multiplayer i am have same problem but i am delayed commands problem..