The International Simutrans Forum

Simutrans Extended => Simutrans Extended Paksets => Pak128.Britain-Ex => Topic started by: Spenk009 on December 05, 2017, 05:05:00 PM

Title: [0.9.3 - 05.12.17] Westinghouse lms box is available, but no signals
Post by: Spenk009 on December 05, 2017, 05:05:00 PM
I started a game in 1950 and discovered that the Westinghouse LMS Signalbox has no signals to be built in that age.

Upon inspection I've found that the searchlight signals (signal_groups=4) are phased out in January 1948, while the signalbox remains constructable until May 1960.

Researching the topic, I've stumbled across this: "While this signalling was installed by the Great Western in the 1930s it continued in use until after the demise of steam on the Western Region in the 1960s. Some of the Great Western signals were modified to the LNER style, notably on the main line out of Paddington near Southall." and http://forum.signalbox.org/viewtopic.php?f=5&t=3409 (http://forum.signalbox.org/viewtopic.php?f=5&t=3409) shows a signal built/provided in 1957.

I would therefore suggest moving the signal build date back to 1960, rather than reducing the signal type's run to 14 years.

Additionally I noticed a mistake in the naming of the choose signal, currently named: "Five aspect searchlight chose signal". This could be amended with the fix.

Thoughts on the subject of build dates?
Title: Re: [0.9.3 - 05.12.17] Westinghouse lms box is available, but no signals
Post by: jamespetts on December 05, 2017, 06:37:58 PM
Thank you for this: that is helpful. Whilst the type of searchlight signal to which you referred is not part of the same system as the LMS system of the 1930s, I have nonetheless put the retirement date of the signals back to 1960 as it is plausible to imagine that this 1930s signalling technology might well have continued largely unchanged until then if railway companies had wanted it.
Title: Re: [0.9.3 - 05.12.17] Westinghouse lms box is available, but no signals
Post by: Spenk009 on December 17, 2017, 08:18:55 AM
Thank you very much. It really is a what-if situation with some of the content.
Title: Re: [0.9.3 - 05.12.17] Westinghouse lms box is available, but no signals
Post by: jamespetts on December 17, 2017, 12:49:00 PM
Thank you very much. It really is a what-if situation with some of the content.

Indeed - that does make it difficult to calibrate sometimes.