The International Simutrans Forum

Development => Bug Reports => Topic started by: danivenk on February 26, 2018, 09:43:22 PM

Title: Graphics Glitch Simutrans Pak128 - r8365
Post by: danivenk on February 26, 2018, 09:43:22 PM
I have had this strange glitch for a while now and it is driving me nuts.
It sometimes comes and goes and then suddenly returns...
Today I found out that it only happens on Add-on rails.
Is there a way to fix this and I still can use the add-ons?

EDIT: Just found out it isn't only limited to rails.

danivenk

Screenshot (https://www.dropbox.com/s/8u0j6bloykzkqqg/Screenshot%202018-02-26%2022.38.23.png?dl=0)
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: prissi on February 27, 2018, 05:52:58 AM
Could you be a little more specific where the glitch is? Do you mean the red reservation or building marks?
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: danivenk on February 27, 2018, 07:23:29 AM
Please take a look at the screenshot that I attached. While a convoi moves somehow part of thw way lies on top of the convoi.
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: DrSuperGood on February 27, 2018, 08:00:42 AM
I assume you are referring to how it appears parts of some coaches are missing? Could this not be a pakset bug?
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: danivenk on February 27, 2018, 08:21:36 AM
Could this not be a pakset bug?
As in that it only happens in Pak128? I don't know...
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: prissi on February 28, 2018, 06:53:57 AM
Most probably wrong alinged vehciles ... If a vehicle reached in the previous tile, then such errors are possible, especially if the computer is in fast forward or otherwise challenged to keep the display rate high.
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: danivenk on February 28, 2018, 08:08:22 AM
Most probably wrong alinged vehciles ... If a vehicle reached in the previous tile, then such errors are possible, especially if the computer is in fast forward or otherwise challenged to keep the display rate high.
This would mean that every rail/road vehicle that I use is wrongly aligned... Even though I use Japanese add-ons which a lot of people use and when I ask around nobody has the same problem...
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: prissi on March 01, 2018, 02:36:07 AM
If you are using fast forward, the directional clipping is switched off and especially with the japanese addons will result in such artefacts. This can also happen in normal mode, if Simutrans thinks that screen updates are taking too long.

Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: danivenk on March 01, 2018, 04:32:55 PM
If you are using fast forward, the directional clipping is switched off and especially with the japanese addons will result in such artefacts. This can also happen in normal mode, if Simutrans thinks that screen updates are taking too long.
I mostely use normal mode. How can I fix this? Because not all of my RAM/CPU seems to be used when using Simutrans...
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: prissi on March 02, 2018, 02:20:12 AM
That is an inherent limitation of the drawing system, which is why vehicles in most sets are aligned the way they are. Only pak128.japan aligns them differently, ans some vehicles in pak128 are off as well.
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: gauthier on March 02, 2018, 05:20:01 PM
Quote
some vehicles in pak128 are off as well.
Which ones ? :police:
Title: Re: Graphics Glitch Simutrans Pak128 - r8365
Post by: prissi on March 03, 2018, 02:04:10 PM
I think it was at least some buses. But I usually never play pak128, so I forgot.