The International Simutrans Forum

Simutrans Extended => Simutrans-Extended paksets => Pak256.Ex => Topic started by: sailingairplane on December 03, 2019, 11:35:54 PM

Title: Unable to load pak256
Post by: sailingairplane on December 03, 2019, 11:35:54 PM
Hello!

Just recently downloaded pak256, however the game crashes when the game attempts to load this pak (screenshot attached). When playing with Simutrans-Extended, all other paks work fine (tested Britan-Ex, Sweden-Ex and pak.64-Ex). I can't find any log files located anywhere, so I'm not sure whats going wrong.

Running:
Simutrans 120.2.1 Extended Nightly development build 13.4
On Windows 7 SP1

Dell Optiplex-990 with additional GeForce GT220

Thanks in advance for any help provided.

Screenshot link (postimg)
https://postimg.cc/yJvWpX29
Title: Re: Unable to load pak256
Post by: Phystam on December 04, 2019, 02:59:14 AM
Thank you for the report.

At first, please try to use the latest version of Simutrans-Extended(14.5). If it does not work, let me know the problem again.
Title: Re: Unable to load pak256
Post by: sailingairplane on December 04, 2019, 08:45:20 AM
Ah, I didn’t realise how old my version of Simutrans Extended was. I’ve upgraded to 14.5, and the game now loads, thank you very much!
Title: Re: Unable to load pak256
Post by: Andarix on December 04, 2019, 09:00:18 AM
Ah, I didn’t realise how old my version of Simutrans Extended was. I’ve upgraded to 14.5, and the game now loads, thank you very much!

Simutrans-Extended has not released any releases for a long time. Only nightly builds.

The version 14.5 is misleading, because this version number has not been changed for 2 or 3 years, but there are countless Nightly builds with it.

Title: Re: Unable to load pak256
Post by: Phystam on December 04, 2019, 03:39:30 PM
I think that the version number of Simutrans-EXTENDED always signifies the nightly build version.
In the Experimental era, there were stable versions, but in the Extended era, there are no stable versions but nightly build versions.
The problem is the makeobj-extended version. There are small changes between the versions for 13.4 and later versions. We use the latest version of makeobj-extended, that is why you cannot load with your previous simutrans-extended version.