The International Simutrans Forum

Simutrans Extended => Simutrans-Extended bug reports => Simutrans-Extended development => Simutrans-Extended closed bug reports => Topic started by: Phystam on March 31, 2020, 12:38:54 PM

Title: segfault with demo.sve
Post by: Phystam on March 31, 2020, 12:38:54 PM
I got a segfault message in demo.sve.
(https://media.discordapp.net/attachments/665986412641779712/694525928650309642/unknown.png)
Title: Re: segfault with demo.sve
Post by: jamespetts on April 02, 2020, 09:55:40 AM
Thank you for your report. I am afraid that I am having trouble reproducing this. May I ask at what point in time in demo.sve (i.e, month and in-game time) that this occurs?
Title: Re: segfault with demo.sve
Post by: freddyhayward on April 02, 2020, 07:55:45 PM
The backtrace looks familiar to me - I believe that this occurred in another save when I deleted an intercity road using the public player.
Title: Re: segfault with demo.sve
Post by: jamespetts on April 03, 2020, 12:26:56 PM
Phystam - can I check whether the above error occurred after deleting a road?
Title: Re: segfault with demo.sve
Post by: Phystam on April 03, 2020, 05:20:38 PM
Just waiting -- I did nothing.
Title: Re: segfault with demo.sve
Post by: Vladki on April 03, 2020, 05:25:28 PM
Didn't you rotate the map?
Title: Re: segfault with demo.sve
Post by: Phystam on April 03, 2020, 08:43:43 PM
neither.
Title: Re: segfault with demo.sve
Post by: jamespetts on April 06, 2020, 05:58:55 PM
Can I ask again, therefore, how long that you waited (i.e., what the in-game time was when the crash occurred)? I need to know this in order to check whether I have waited long enough.

However, I should note that the 64-bit windows nightly builds had not been compiling between the 29th of March and now (and I have just fixed them). I suggest that you re-test with the Windows 64-bit build with to-day's date to check whether that solves the problem, as some crashes have been solved since around the 29th of March, I think.
Title: Re: segfault with demo.sve
Post by: freddyhayward on April 07, 2020, 03:12:26 AM
Quote from: jamespetts on April 06, 2020, 05:58:55 PMCan I ask again, therefore, how long that you waited (i.e., what the in-game time was when the crash occurred)?
In my testing of demo.sve on the latest linux build, I usually get a crash in under two months, often ~4 hours into the starting month (May).
Title: Re: segfault with demo.sve
Post by: Ranran on April 07, 2020, 10:21:53 AM
Quote from: jamespetts on April 06, 2020, 05:58:55 PMI suggest that you re-test with the Windows 64-bit build with to-day's date to check whether that solves the problem, as some crashes have been solved since around the 29th of March, I think.
I tested on build # a8918ba windows 64-bit version, but frozen on 1945 June 2:52:06/6:24:00 with demo.sve.

EDIT:
Timing seems random, as reported by freddyhayward. But in my case it's a freeze rather than a crash. CPU usage increases when it freezes. Some freeze in May, others freeze in July.

EDIT2:
In May, I also confirmed a crash without causing a freeze.
Title: Re: segfault with demo.sve
Post by: jamespetts on April 07, 2020, 03:12:14 PM
I am afraid that I have been unable to reproduce this either with a debug build or with the latest downloaded release build, both with fast-forwarding and not fast-forwarding and waiting until August.
Title: Re: segfault with demo.sve
Post by: Phystam on April 08, 2020, 11:13:03 AM
I can no longer reproduce it for some reason. Thank you.
Title: Re: segfault with demo.sve
Post by: jamespetts on April 08, 2020, 11:37:01 AM
Thank you for letting me know.
Title: Re: segfault with demo.sve
Post by: Ranran on April 08, 2020, 11:42:20 AM
I still cannot reach the end of WW2.
However, once I save, I can move on, but I can never continue playing for more than three months in my PC.
CPU usage is around 7% and there is still room for memory usage.
Since your computer is high spec, I'm guessing it may take longer to cause a crash or it will not happen. (´・ω・`)
Title: Re: segfault with demo.sve
Post by: jamespetts on April 08, 2020, 09:16:35 PM
Quote from: Ranran on April 08, 2020, 11:42:20 AM
I still cannot reach the end of WW2.
However, once I save, I can move on, but I can never continue playing for more than three months in my PC.
CPU usage is around 7% and there is still room for memory usage.
Since your computer is high spec, I'm guessing it may take longer to cause a crash or it will not happen. (´・ω・`)

Without being able to reproduce this reliably, this is likely to be virtually impossible to fix. If you can find any other map on which this can be reproduced with greater reliability, that would be very helpful, as I have simply not been able to provoke any freeze within any reasonable period (even after leaving it running for many hours) with demo.sve.