The International Simutrans Forum

Simutrans Extended => Simutrans-Extended bug reports => Simutrans-Extended development => Simutrans-Extended closed bug reports => Topic started by: VOLVO on June 22, 2020, 01:44:26 PM

Title: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: VOLVO on June 22, 2020, 01:44:26 PM
After some changes to a route some horse carts were teleported to depot because their destinations were reset to somewhere outside of their range, and by attempting to click on the depot that hold them at (6319,116), the game crashed immediately.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: jamespetts on June 22, 2020, 02:19:41 PM
Quote from: VOLVO on June 22, 2020, 01:44:26 PM
After some changes to a route some horse carts were teleported to depot because their destinations were reset to somewhere outside of their range, and by attempting to click on the depot that hold them at (6319,116), the game crashed immediately.

Thank you for the report. Unfortunately, however, I am not able to reproduce this.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: Huitsi on June 22, 2020, 05:05:56 PM
I'm currently experiencing this segfault with my depot at (2010,2456). I had it happen with another depot earlier but that stopped. It seems to have something to do with convoys having entered the depot, but I haven't managed to intentionally reproduce it. Active player doesn't seem to matter, as for instance VOLVO's depot segfaults for me too.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: Rollmaterial on June 22, 2020, 08:25:53 PM
I also get this crash offline. It seems to happen when there is a convoy in the depot.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: freddyhayward on June 23, 2020, 01:04:31 AM
I had previously experienced this issue, but it seems to have been fixed in Ranran's patch, which was merged 12 hours ago as of writing and should come into effect on the next server reset.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: jamespetts on June 23, 2020, 11:33:26 AM
Splendid, thank you for confirming; I did wonder whether Ranran's fix might have fixed this. Can anyone confirm that this is now working on the server?
Thank you to Ranran for fixing this.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: VOLVO on June 24, 2020, 02:15:49 AM
Quote from: jamespetts on June 23, 2020, 11:33:26 AM
Splendid, thank you for confirming; I did wonder whether Ranran's fix might have fixed this. Can anyone confirm that this is now working on the server?
Thank you to Ranran for fixing this.

I have tried to click on that depot again and it worked fine, so I assume the bug is resolved, thanks.
Title: Re: Crashed with clicking on a certain depot on Bridgewater-Brunel server game
Post by: jamespetts on June 24, 2020, 10:34:43 AM
Quote from: VOLVO on June 24, 2020, 02:15:49 AM
I have tried to click on that depot again and it worked fine, so I assume the bug is resolved, thanks.


Splendid, thank you for confirming.