The International Simutrans Forum

Development => Patches & Projects => Topic started by: Frank on September 18, 2010, 05:50:09 AM

Title: Patch - translate transformer
Post by: Frank on September 18, 2010, 05:50:09 AM
Quote from: IgorEliezer on September 11, 2010, 10:27:40 PM
I have a slight impression that transformers are not translatable. :/

rename "Aufspanntransformator" to "PowerSource"
rename "Abspanntransformator" to "PowerDest"

and translate this
Title: Re: Patch - translate transformer
Post by: TurfIt on September 18, 2010, 06:47:30 AM

- const char *get_name() const {return "Aufspanntransformator";}
+ const char *get_name() const {return translator::translate("PowerSource");}

The call to the translator is unnecessary here. The "Aufspanntransformator" name is already being passed to the translator for display in the info window title; The appropriate entry in the xx.tab file is simply missing...


- const char *get_name() const {return "Aufspanntransformator";}
+ const char *get_name() const {return "PowerSource";}

would be fine to change from a german to an english basis for the translator. Same for "PowerDest".
Title: Re: Patch - translate transformer
Post by: Frank on September 18, 2010, 07:10:49 AM
Quote from: TurfIt on September 18, 2010, 06:47:30 AM
...
- const char *get_name() const {return "Aufspanntransformator";}
+ const char *get_name() const {return "PowerSource";}

would be fine to change from a german to an english basis for the translator. Same for "PowerDest".

ops, sorry

ok, import to Translator

rename can later